aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-sis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xf86-video-sis/APKBUILD')
-rw-r--r--main/xf86-video-sis/APKBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/main/xf86-video-sis/APKBUILD b/main/xf86-video-sis/APKBUILD
index a0400f02ff..18ba6e91ca 100644
--- a/main/xf86-video-sis/APKBUILD
+++ b/main/xf86-video-sis/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-sis
pkgver=0.10.7
-pkgrel=2
+pkgrel=4
pkgdesc="X.org SiS video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -12,14 +12,21 @@ makedepends="pkgconfig xorg-server-dev videoproto renderproto xproto
fontsproto xf86dgaproto xineramaproto randrproto xextproto mesa-dev
xf86driproto glproto libxi-dev"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ sis-0.10.7-git.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure --prefix=/usr || return 1
@@ -27,9 +34,14 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="f01e5e20e37342acf1983d269886171b xf86-video-sis-0.10.7.tar.bz2"
+md5sums="f01e5e20e37342acf1983d269886171b xf86-video-sis-0.10.7.tar.bz2
+268a460c217b9108c2e43608a066198a sis-0.10.7-git.patch"
+sha256sums="be2eb6acba081e88dabc5be9db379e3da89a4d4edeb68064f204bf343a411cd0 xf86-video-sis-0.10.7.tar.bz2
+7cc3c746f0921b72b4a2cae599790d115424f813dde8b74a0fe8222152a9c4cf sis-0.10.7-git.patch"
+sha512sums="095fd47803e8296ca3769b5c62e9399b6759023660c42b215b708dfed456e3cf2dad93b8abcb48887bd40e0d0b1435d4e1d711a721f5cb55bef4d7093ab387fa xf86-video-sis-0.10.7.tar.bz2
+985e067fbf21d5151b96d497a4325d98d1fcb4f8b3bb3fa7bf7be7574a343b4bca2460545cb60048ec8b023c03249c18062db0c80cadb899a20d9a3dc41563e4 sis-0.10.7-git.patch"