aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-sis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xf86-video-sis/APKBUILD')
-rw-r--r--main/xf86-video-sis/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/main/xf86-video-sis/APKBUILD b/main/xf86-video-sis/APKBUILD
new file mode 100644
index 0000000000..f80f9382c4
--- /dev/null
+++ b/main/xf86-video-sis/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-sis
+pkgver=0.10.3
+pkgrel=2
+pkgdesc="X.org SiS video driver"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig xorg-server-dev videoproto renderproto xproto
+ fontsproto xf86dgaproto xineramaproto randrproto xextproto mesa-dev
+ xf86driproto glproto libxi-dev"
+
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="dd930928b5ed7fcf34e3be4d43202ec7 xf86-video-sis-0.10.3.tar.bz2"