aboutsummaryrefslogtreecommitdiffstats
path: root/main/xfce4-battery-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xfce4-battery-plugin/APKBUILD')
-rw-r--r--main/xfce4-battery-plugin/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/xfce4-battery-plugin/APKBUILD b/main/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 0000000000..457d30e92b
--- /dev/null
+++ b/main/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-battery-plugin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A battery monitor plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+arch="all"
+license="GPL-2"
+makedepends="xfce4-panel-dev libxfcegui4-dev perl-xml-parser intltool"
+install=
+source="http://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ sysfs-temp.patch
+ "
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="2696307f34f6b9630fcaaea102004e78 xfce4-battery-plugin-1.0.0.tar.bz2
+8c797bdd29b431284377a7f08ddcd50e sysfs-temp.patch"