aboutsummaryrefslogtreecommitdiffstats
path: root/main/xfce4-notes-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xfce4-notes-plugin/APKBUILD')
-rw-r--r--main/xfce4-notes-plugin/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/main/xfce4-notes-plugin/APKBUILD b/main/xfce4-notes-plugin/APKBUILD
index fba2bfba05..ced0e4be06 100644
--- a/main/xfce4-notes-plugin/APKBUILD
+++ b/main/xfce4-notes-plugin/APKBUILD
@@ -2,22 +2,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfce4-notes-plugin
pkgver=1.7.7
-pkgrel=5
+pkgrel=6
pkgdesc="Notes plugin for the Xfce4 desktop"
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
arch="all"
license="GPL"
depends=
-makedepends="xfce4-panel-dev libunique-dev libxfcegui4-dev"
+makedepends="xfce4-panel-dev libunique-dev libxfce4ui-dev"
install=
subpackages="$pkgname-lang"
-source="http://archive.xfce.org/src/panel-plugins/xfce4-notes-plugin/1.7/xfce4-notes-plugin-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-notes-plugin/1.7/xfce4-notes-plugin-$pkgver.tar.bz2
+ xfce-notes-plugin-libxfce4ui.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -39,4 +45,9 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="42b924b23f2fec6a1099e9b7a87db4a3 xfce4-notes-plugin-1.7.7.tar.bz2"
+md5sums="42b924b23f2fec6a1099e9b7a87db4a3 xfce4-notes-plugin-1.7.7.tar.bz2
+655766bb8d76234d2fedb7e9941808e5 xfce-notes-plugin-libxfce4ui.patch"
+sha256sums="a7baa105b37ad05dea4d6b55d98fd3214c77ad5c7a0e91471d4906c81e5f5217 xfce4-notes-plugin-1.7.7.tar.bz2
+e3419840402bd773e1c1e6bf582b48b897485906d676e683cbe70825cee663bb xfce-notes-plugin-libxfce4ui.patch"
+sha512sums="27172da495ee800c181e22839eb2761f3951c1ab18030680af28d132b6014fd5705ca7bbdcea77520afa55d242dc1351f1fcee0936d47ef6847528d5001fc52c xfce4-notes-plugin-1.7.7.tar.bz2
+0252cd49344f4f7e1aa4df127f8399d997f9fab09e6ec5d8044bc85e5b9bf7bf2595f41c77da864851dce29f68cdfaa4df29f098e5c11c0ddee367228a8f8a30 xfce-notes-plugin-libxfce4ui.patch"