aboutsummaryrefslogtreecommitdiffstats
path: root/main/xhost/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xhost/APKBUILD')
-rw-r--r--main/xhost/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/xhost/APKBUILD b/main/xhost/APKBUILD
index e00fdd1144..56427358c3 100644
--- a/main/xhost/APKBUILD
+++ b/main/xhost/APKBUILD
@@ -11,8 +11,15 @@ depends=
makedepends="pkgconfig libx11-dev libxmu-dev libxau-dev"
source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build () {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,7 +30,7 @@ build () {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="c7f91b4a750d297f269c2a0a3206a1b2 xhost-1.0.3.tar.bz2"