aboutsummaryrefslogtreecommitdiffstats
path: root/main/xulrunner/mozilla-bsdiff-libbz2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xulrunner/mozilla-bsdiff-libbz2.patch')
-rw-r--r--main/xulrunner/mozilla-bsdiff-libbz2.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/xulrunner/mozilla-bsdiff-libbz2.patch b/main/xulrunner/mozilla-bsdiff-libbz2.patch
new file mode 100644
index 0000000000..52e4c92996
--- /dev/null
+++ b/main/xulrunner/mozilla-bsdiff-libbz2.patch
@@ -0,0 +1,33 @@
+# HG changeset patch
+# User Mike Hommey <mh+mozilla@glandium.org>
+# Date 1302680663 -7200
+# Node ID 0583d58b20a3a0789c46f19ed505cb6e96602ec9
+# Parent 0138798a072ad15edce15d614923a03256946218
+Bug 644692 - Fix bsdiff build failure with system bzip2. r=ted
+
+diff --git a/other-licenses/bsdiff/Makefile.in b/other-licenses/bsdiff/Makefile.in
+--- a/other-licenses/bsdiff/Makefile.in
++++ b/other-licenses/bsdiff/Makefile.in
+@@ -43,17 +43,21 @@ VPATH = @srcdir@
+
+ include $(DEPTH)/config/autoconf.mk
+
+ # This program is output to dist/host/bin because it is only needed by the
+ # build system and is not intended to be included in Mozilla distributions.
+ HOST_PROGRAM = mbsdiff$(BIN_SUFFIX)
+ HOST_CSRCS = bsdiff.c
+
++ifdef MOZ_NATIVE_BZ2
++HOST_LIBS += $(BZ2_LIBS)
++else
+ HOST_LIBS += $(DIST)/host/lib/$(LIB_PREFIX)hostbz2.$(LIB_SUFFIX)
++endif
+
+ ifneq (,$(filter WINCE WINNT,$(HOST_OS_ARCH)))
+ HOST_EXTRA_LIBS += $(call EXPAND_LIBNAME,Ws2_32)
+ endif
+
+ LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/mozapps/update/updater
+
+ include $(topsrcdir)/config/rules.mk
+