aboutsummaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 7d846b3c3f..41ec53f1b6 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=26.0
_ffoxver=$pkgver
-pkgrel=5
+pkgrel=6
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -102,7 +102,10 @@ package() {
cd "$_builddir"
# only used for startupcache creation.
- paxctl -c -m */dist/bin/xpcshell || return 1
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+
+ paxctl -c $paxflags */dist/bin/xpcshell || return 1
make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1