aboutsummaryrefslogtreecommitdiffstats
path: root/main/zfs-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/zfs-grsec/APKBUILD')
-rw-r--r--main/zfs-grsec/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/zfs-grsec/APKBUILD b/main/zfs-grsec/APKBUILD
index ef71517a5b..cdc0de4692 100644
--- a/main/zfs-grsec/APKBUILD
+++ b/main/zfs-grsec/APKBUILD
@@ -7,7 +7,7 @@ _name=$_realname-$_flavor
_kpkg=linux-$_flavor
_kver=4.4.14
-_kpkgrel=0
+_kpkgrel=1
_realver=0.6.5.7
_mypkgrel=0
@@ -59,6 +59,8 @@ prepare() {
build() {
cd "$builddir"
export LIBS="$LIBS -lintl"
+ KCFLAGS="-fno-pie" \
+ EXTRA_KCFLAGS="-fno-pie -Wno-error=unused-but-set-variable" \
./configure --prefix=/usr \
--with-tirpc \
--sysconfdir=/etc \
@@ -69,12 +71,15 @@ build() {
--with-linux=/usr/src/linux-headers-${_abi_release} \
--with-spl=/usr/src/spl-${_realver} \
|| return 1
- make || return 1
+ make KCFLAGS="-fno-pie" \
+ EXTRA_KCFLAGS="-fno-pie" \
+ || return 1
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make KCFLAGS="-fno-pie" DESTDIR="$pkgdir" \
+ install || return 1
}
dev() {