aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/neon/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/main/neon/APKBUILD b/main/neon/APKBUILD
index 01614bf0a4..1ce80ed05d 100644
--- a/main/neon/APKBUILD
+++ b/main/neon/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=neon
pkgver=0.30.2
-pkgrel=2
+pkgrel=3
pkgdesc="HTTP and WebDAV client library with a C interface"
url="http://www.webdav.org/neon/"
arch="all"
@@ -14,7 +14,7 @@ source="https://fossies.org/linux/www/neon-0.30.2.tar.gz
fix-libressl.patch"
build () {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,18 +26,18 @@ build () {
--enable-shared \
--disable-static \
--enable-threadsafe-ssl=posix \
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
- || return 1
- make || return 1
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="e28d77bf14032d7f5046b3930704ef41 neon-0.30.2.tar.gz
-ad495360898a5367ef411fa086750044 fix-libressl.patch"
-sha256sums="db0bd8cdec329b48f53a6f00199c92d5ba40b0f015b153718d1b15d3d967fbca neon-0.30.2.tar.gz
-b10b9a213f178012739c3bafe73b5c05a744e746ba41fad4ca0fc2831d341244 fix-libressl.patch"
sha512sums="634caf87522e0bd2695c6fba39cae2465e403f9fbd8007eb10e4e035c765d24cb8da932c67bfa35c34aa51b90c7bc7037ebebaa1ec43259366d5d07233efc631 neon-0.30.2.tar.gz
a9ef4d5ef44518ac4df81a3e3d7532cf1eb7ee4018fd9c05ceeff0bc11d368bf2253af410e54142d73503772eb9e470ad6c0c7cd28f08d9d918b9587a685e1fc fix-libressl.patch"