aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/alsa-lib/APKBUILD3
-rw-r--r--main/apk-tools/APKBUILD11
-rw-r--r--main/apk-tools/info-segfault.patch22
-rw-r--r--main/dbus-glib/APKBUILD6
-rw-r--r--main/fetchmail/APKBUILD6
-rw-r--r--main/git/APKBUILD16
-rw-r--r--main/git/git-do-not-dump-core-when-iconv-fails.patch43
-rw-r--r--main/gtk-doc/APKBUILD6
-rw-r--r--main/hunspell/APKBUILD4
-rw-r--r--main/imlib2/APKBUILD15
-rw-r--r--main/imlib2/bufferoverflow.patch13
-rw-r--r--main/imlib2/libpng14.patch12
-rw-r--r--main/libc0.9.32/APKBUILD6
-rw-r--r--main/libc0.9.32/uclibc-libm-pic.patch67
-rw-r--r--main/libc0.9.32/uclibc-resolv-tls.patch15
-rw-r--r--main/libgsf/APKBUILD6
-rw-r--r--main/libtasn1/APKBUILD6
-rw-r--r--main/libxcb/APKBUILD6
-rw-r--r--main/mercurial/APKBUILD6
-rw-r--r--main/php/APKBUILD8
-rw-r--r--main/php/php-install-pear-xml.patch15
21 files changed, 222 insertions, 70 deletions
diff --git a/main/alsa-lib/APKBUILD b/main/alsa-lib/APKBUILD
index ded73194d8..1b4503c92b 100644
--- a/main/alsa-lib/APKBUILD
+++ b/main/alsa-lib/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alsa-lib
pkgver=1.0.23
-pkgrel=0
+pkgrel=1
pkgdesc="An alternative implementation of Linux sound support"
url="http://www.alsa-project.org"
license="GPL"
@@ -19,6 +19,7 @@ build() {
--enable-seq \
--enable-aload \
--disable-dependency-tracking \
+ --without-versioned \
|| return 1
make || return 1
}
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 30f7eb5e91..e9fd040fe7 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,26 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ info-segfault.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
license=GPL-2
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's:-Werror::' Make.rules
for i in ../*.patch; do
[ -f $i ] || continue
patch -p1 -i $i || return 1
done
+}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
make || return 1
make static || return 1
make DESTDIR="$pkgdir" install
@@ -40,4 +44,5 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="c87cb88f90eb8d7021d37e3b5386863d apk-tools-2.0.2.tar.bz2"
+md5sums="c87cb88f90eb8d7021d37e3b5386863d apk-tools-2.0.2.tar.bz2
+aeab86a00119f9945edd6d3c3a8bb9c1 info-segfault.patch"
diff --git a/main/apk-tools/info-segfault.patch b/main/apk-tools/info-segfault.patch
new file mode 100644
index 0000000000..9479fade30
--- /dev/null
+++ b/main/apk-tools/info-segfault.patch
@@ -0,0 +1,22 @@
+commit 87420aaf295f58847332ba3aa89691a0259baace
+Author: Timo Teras <timo.teras@iki.fi>
+Date: Wed May 5 08:56:06 2010 +0300
+
+ info: fix querying of removed, but referenced packages
+
+ Check that package name has packages associated with it before
+ dereferencing the pointer. Fixes #345.
+
+diff --git a/src/info.c b/src/info.c
+index 7ca486c..d944fca 100644
+--- a/src/info.c
++++ b/src/info.c
+@@ -283,7 +283,7 @@ static int info_package(struct info_ctx *ctx, struct apk_database *db,
+
+ for (i = 0; i < argc; i++) {
+ name = apk_db_query_name(db, APK_BLOB_STR(argv[i]));
+- if (name == NULL) {
++ if (name == NULL || name->pkgs == NULL) {
+ apk_error("Not found: %s", argv[i]);
+ return 1;
+ }
diff --git a/main/dbus-glib/APKBUILD b/main/dbus-glib/APKBUILD
index 4939ca590d..799560fbab 100644
--- a/main/dbus-glib/APKBUILD
+++ b/main/dbus-glib/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus-glib
-pkgver=0.82
-pkgrel=1
+pkgver=0.86
+pkgrel=0
pkgdesc="GLib bindings for DBUS"
url="http://www.freedesktop.org/wiki/Software/DBusBindings"
license="GPL"
@@ -25,4 +25,4 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="aa2a4517de0e9144be3bce2cf8cdd924 dbus-glib-0.82.tar.gz"
+md5sums="cd0ab148fb0c786fc88be49d19971f50 dbus-glib-0.86.tar.gz"
diff --git a/main/fetchmail/APKBUILD b/main/fetchmail/APKBUILD
index 3c099e7821..5e1ba96723 100644
--- a/main/fetchmail/APKBUILD
+++ b/main/fetchmail/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetchmail
-pkgver=6.3.16
-pkgrel=1
+pkgver=6.3.17
+pkgrel=0
pkgdesc="A remote-mail retrieval and forwarding utility"
url="http://fetchmail.berlios.de/"
license="GPL"
@@ -41,5 +41,5 @@ fetchmailconf() {
mv usr/lib "$subpkgdir"/usr/
}
-md5sums="1a40acb371376c7d54fe468c99dfc216 fetchmail-6.3.16.tar.bz2
+md5sums="7b1d449ecddb6164e22c32854adc4a75 fetchmail-6.3.17.tar.bz2
b27fe01a7c25534d62d175c8ba22fc48 fetchmail.initd"
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 728fd7b19a..5d5153c2a2 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
pkgver=1.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="GIT - the stupid content tracker"
url="http://git.or.cz/"
license="GPL2"
@@ -10,6 +10,7 @@ subpackages="$pkgname-doc $pkgname-perl"
makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev"
source="http://kernel.org/pub/software/scm/git/git-$pkgver.tar.bz2
bb-tar.patch
+ git-do-not-dump-core-when-iconv-fails.patch
"
_makeopts="NO_ICONV=YesPlease
@@ -17,14 +18,16 @@ _makeopts="NO_ICONV=YesPlease
NO_TCLTK=YesPlease
NO_SVN_TESTS=YesPlease"
-build () {
- cd $srcdir/$pkgname-$pkgver
- patch -p1 -i ../bb-tar.patch || return 1
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i "$srcdir"/bb-tar.patch || return 1
+ patch -p1 -i "$srcdir"/git-do-not-dump-core-when-iconv-fails.patch \
+ || return 1
make prefix=/usr DESTDIR="$pkgdir" $_makeopts || return 1
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
make prefix=/usr DESTDIR="$pkgdir" $_makeopts install
}
@@ -43,4 +46,5 @@ perl() {
md5sums="3da231dbe82ad103373cb530ae7475d5 git-1.7.1.tar.bz2
-e63a201556c4f089de790805c09a2e5b bb-tar.patch"
+e63a201556c4f089de790805c09a2e5b bb-tar.patch
+7c660517316261b383a094ef03aad0aa git-do-not-dump-core-when-iconv-fails.patch"
diff --git a/main/git/git-do-not-dump-core-when-iconv-fails.patch b/main/git/git-do-not-dump-core-when-iconv-fails.patch
new file mode 100644
index 0000000000..b338ee4809
--- /dev/null
+++ b/main/git/git-do-not-dump-core-when-iconv-fails.patch
@@ -0,0 +1,43 @@
+commit 43acff34b902c38808ac0f326090f2516250e1f0
+Author: Jonathan Nieder <jrnieder@gmail.com>
+Date: Sat May 8 18:17:29 2010 -0500
+
+ cherry-pick: do not dump core when iconv fails
+
+ When cherry-picking, usually the new and old commit encodings are both
+ UTF-8. Most old iconv implementations do not support this trivial
+ conversion, so on old platforms, out->message remains NULL, and later
+ attempts to read it segfault.
+
+ Fix this by noticing the input and output encodings match and skipping
+ the iconv step, like the other reencode_string() call sites already do.
+ Also stop segfaulting on other iconv failures: if iconv fails for some
+ other reason, the best we can do is to pass the old message through.
+
+ This fixes a regression introduced in v1.7.1-rc0~15^2~2 (revert:
+ clarify label on conflict hunks, 2010-03-20).
+
+ Reported-by: Andreas Krey <a.krey@gmx.de>
+ Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
+ Signed-off-by: Junio C Hamano <gitster@pobox.com>
+
+diff --git a/builtin/revert.c b/builtin/revert.c
+index 778a56e..7d68ef7 100644
+--- a/builtin/revert.c
++++ b/builtin/revert.c
+@@ -109,8 +109,13 @@ static int get_message(const char *raw_message, struct commit_message *out)
+ encoding = "UTF-8";
+ if (!git_commit_encoding)
+ git_commit_encoding = "UTF-8";
+- if ((out->reencoded_message = reencode_string(raw_message,
+- git_commit_encoding, encoding)))
++
++ out->reencoded_message = NULL;
++ out->message = raw_message;
++ if (strcmp(encoding, git_commit_encoding))
++ out->reencoded_message = reencode_string(raw_message,
++ git_commit_encoding, encoding);
++ if (out->reencoded_message)
+ out->message = out->reencoded_message;
+
+ abbrev = find_unique_abbrev(commit->object.sha1, DEFAULT_ABBREV);
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 9c86f49ccf..7b80401752 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk-doc
-pkgver=1.13
+pkgver=1.14
pkgrel=0
pkgdesc="Documentation tool for public library API"
url="http://www.gtk.org/gtk-doc/"
license="GPL FDL"
depends="docbook-xsl gnome-doc-utils perl pkgconfig"
-makedepends="rarian-dev"
+makedepends="rarian-dev py-libxml2 gettext"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
build() {
@@ -20,4 +20,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="27940d6cd5c9dcda8fc003043d8c299a gtk-doc-1.13.tar.bz2"
+md5sums="7aa8a1262c70692ebbdf33395fddd5c4 gtk-doc-1.14.tar.bz2"
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index aea33affb6..efd3476c39 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hunspell
-pkgver=1.2.10
+pkgver=1.2.11
pkgrel=0
pkgdesc="Spell checker and morphological analyzer library and program"
url="http://hunspell.sourceforge.net/"
@@ -22,4 +22,4 @@ package() {
make -j1 DESTDIR="$pkgdir" install || return 1
rm -rf "$pkgdir"/usr/share/locale/locale.alias
}
-md5sums="cc701ae1015e5442e85d592c325ea8aa hunspell-1.2.10.tar.gz"
+md5sums="8f57cdc4db091d69e1f682ed4d8ab282 hunspell-1.2.11.tar.gz"
diff --git a/main/imlib2/APKBUILD b/main/imlib2/APKBUILD
index 5176e2e58e..fcd4e38a0e 100644
--- a/main/imlib2/APKBUILD
+++ b/main/imlib2/APKBUILD
@@ -1,23 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imlib2
-pkgver=1.4.2
-pkgrel=5
+pkgver=1.4.4
+pkgrel=0
pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
url="http://sourceforge.net/projects/enlightenment/"
license="BSD"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="tiff-dev giflib-dev bzip2-dev freetype-dev libxext-dev
- libpng-dev libid3tag-dev jpeg-dev libsm-dev zlib-dev"
+ libpng-dev libid3tag-dev jpeg-dev libsm-dev zlib-dev util-linux-ng-dev"
source="http://downloads.sourceforge.net/enlightenment/$pkgname-$pkgver.tar.bz2
- bufferoverflow.patch
- libpng14.patch"
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -Np0 -i "$srcdir"/bufferoverflow.patch || return 1
- patch -Np1 -i "$srcdir"/libpng14.patch || return 1
}
build() {
@@ -36,6 +33,4 @@ package() {
make DESTDIR=$pkgdir install || return 1
install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
-md5sums="9f15568e76ebda9092c571e0df261f54 imlib2-1.4.2.tar.bz2
-76def1fe0ac2ac1686ff24d29979606f bufferoverflow.patch
-68f671641e298ef7eead0aded4087c53 libpng14.patch"
+md5sums="b6de51879502e857d5b1f7622267a030 imlib2-1.4.4.tar.bz2"
diff --git a/main/imlib2/bufferoverflow.patch b/main/imlib2/bufferoverflow.patch
deleted file mode 100644
index 397b43fb8c..0000000000
--- a/main/imlib2/bufferoverflow.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/modules/loaders/loader_xpm.c
-+++ src/modules/loaders/loader_xpm.c.new
-@@ -246,8 +246,8 @@
- return 0;
- }
- ptr = im->data;
-- end = ptr + (sizeof(DATA32) * w * h);
- pixels = w * h;
-+ end = ptr + pixels;
- }
- else
- {
-
diff --git a/main/imlib2/libpng14.patch b/main/imlib2/libpng14.patch
deleted file mode 100644
index 0409228401..0000000000
--- a/main/imlib2/libpng14.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur imlib2-1.4.2-orig/src/modules/loaders/loader_png.c imlib2-1.4.2/src/modules/loaders/loader_png.c
---- imlib2-1.4.2-orig/src/modules/loaders/loader_png.c 2010-01-19 03:37:21.000000000 -0500
-+++ imlib2-1.4.2/src/modules/loaders/loader_png.c 2010-01-19 03:38:51.000000000 -0500
-@@ -38,7 +38,7 @@
-
- /* if we haven't read the header before, set the header data */
- fread(buf, 1, PNG_BYTES_TO_CHECK, f);
-- if (!png_check_sig(buf, PNG_BYTES_TO_CHECK))
-+ if (png_sig_cmp(buf, 0, PNG_BYTES_TO_CHECK))
- {
- fclose(f);
- return 0;
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index db7a9b0c18..47bc5862ea 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=100507
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=0
+pkgrel=2
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -19,6 +19,8 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
compat-stack-guard.patch
0001-static-build-fix-internal-locking-weaks-to-get-pulle.patch
0002-resolv-various-memory-corruption-and-off-by-one-fixe.patch
+ uclibc-libm-pic.patch
+ uclibc-resolv-tls.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -96,5 +98,7 @@ md5sums="46e98672dc2a4309d9a7c65b4e626845 libc0.9.32-0.9.32_alpha0_git100507.ta
4d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch
826666b365f2d63a71d67eb76c94f7bc 0001-static-build-fix-internal-locking-weaks-to-get-pulle.patch
0800a489a738c7b1d8c3643cb9806926 0002-resolv-various-memory-corruption-and-off-by-one-fixe.patch
+2f9739a980be24a842c57516155c7885 uclibc-libm-pic.patch
+d08831b452acdeaa3037525ee617edab uclibc-resolv-tls.patch
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"
diff --git a/main/libc0.9.32/uclibc-libm-pic.patch b/main/libc0.9.32/uclibc-libm-pic.patch
new file mode 100644
index 0000000000..ad87b78b24
--- /dev/null
+++ b/main/libc0.9.32/uclibc-libm-pic.patch
@@ -0,0 +1,67 @@
+GCC can emit prologue/epilogue code for the functions in various
+different cases:
+ - frame pointers
+ - PIC build (to load ebx for indirect calls/jumps)
+ - forced stack smashing protection
+
+If we used jump in such cases, we'd corrupt the call stack and
+crash.
+
+Signed-off-by: Timo Teräs <timo.teras at iki.fi>
+---
+ libm/ldouble_wrappers.c | 12 +++++++-----
+ 1 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/libm/ldouble_wrappers.c b/libm/ldouble_wrappers.c
+index 7d5af90..5b424dc 100644
+--- a/libm/ldouble_wrappers.c
++++ b/libm/ldouble_wrappers.c
+@@ -60,7 +60,9 @@ long long func##l(long double x) \
+ * The return value is returned in st(0) per ABI in both cases (returning
+ * a long double or returning a double). So we can simply jump to func.
+ * Using __GI_func in jump to make optimized intra-library jump.
+- * gcc will still generate a useless "ret" after asm. Oh well...
++ *
++ * We do need to use call (instead of tail jump) as gcc can create
++ * stack frame, and push/modify/pop ebx during PIC build.
+ */
+ # define WRAPPER1(func) \
+ long double func##l(long double x) \
+@@ -69,7 +71,7 @@ long double func##l(long double x) \
+ __asm ( \
+ " fldt %1\n" \
+ " fstpl %1\n" \
+- " jmp " __stringify(__GI_##func) "\n" \
++ " call " __stringify(__GI_##func) "\n" \
+ : "=t" (st_top) \
+ : "m" (x) \
+ ); \
+@@ -82,7 +84,7 @@ int func##l(long double x) \
+ __asm ( \
+ " fldt %1\n" \
+ " fstpl %1\n" \
+- " jmp " __stringify(__GI_##func) "\n" \
++ " call " __stringify(__GI_##func) "\n" \
+ : "=a" (ret) \
+ : "m" (x) \
+ ); \
+@@ -95,7 +97,7 @@ long func##l(long double x) \
+ __asm ( \
+ " fldt %1\n" \
+ " fstpl %1\n" \
+- " jmp " __stringify(__GI_##func) "\n" \
++ " call " __stringify(__GI_##func) "\n" \
+ : "=a" (ret) \
+ : "m" (x) \
+ ); \
+@@ -108,7 +110,7 @@ long long func##l(long double x) \
+ __asm ( \
+ " fldt %1\n" \
+ " fstpl %1\n" \
+- " jmp " __stringify(__GI_##func) "\n" \
++ " call " __stringify(__GI_##func) "\n" \
+ : "=A" (ret) \
+ : "m" (x) \
+ ); \
+--
+1.7.0.4
diff --git a/main/libc0.9.32/uclibc-resolv-tls.patch b/main/libc0.9.32/uclibc-resolv-tls.patch
new file mode 100644
index 0000000000..45a228517b
--- /dev/null
+++ b/main/libc0.9.32/uclibc-resolv-tls.patch
@@ -0,0 +1,15 @@
+diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
+index 320aec4..f8066d2 100644
+--- a/libc/inet/resolv.c
++++ b/libc/inet/resolv.c
+@@ -2916,8 +2916,8 @@ static void res_sync_func(void)
+ __nameserver[n].sa4 = rp->nsaddr_list[n]; /* struct copy */
+ #endif
+ }
+- __resolv_timeout = rp->retrans;
+- __resolv_attempts = rp->retry;
++ __resolv_timeout = rp->retrans ?: RES_TIMEOUT;
++ __resolv_attempts = rp->retry ?: RES_DFLRETRY;
+ /* Extend and comment what program is known
+ * to use which _res.XXX member(s).
+
diff --git a/main/libgsf/APKBUILD b/main/libgsf/APKBUILD
index f8bdaa9a4b..c8d1e68777 100644
--- a/main/libgsf/APKBUILD
+++ b/main/libgsf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgsf
-pkgver=1.14.16
-pkgrel=1
+pkgver=1.14.18
+pkgrel=0
pkgdesc="The GNOME Structured File Library is a utility library for reading and writing structured file formats."
url="http://www.gnome.org/"
license="GPL LGPL"
@@ -31,4 +31,4 @@ package() {
rm -f "$pkgdir"/usr/share/man/man1/gsf-office-thumbnailer.1
}
-md5sums="8478d83fda0b6e57f36550c11a693ee1 libgsf-1.14.16.tar.bz2"
+md5sums="2c15d875b1931c40c7e7a2368f3ed948 libgsf-1.14.18.tar.bz2"
diff --git a/main/libtasn1/APKBUILD b/main/libtasn1/APKBUILD
index f0075713c8..84b9653276 100644
--- a/main/libtasn1/APKBUILD
+++ b/main/libtasn1/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtasn1
-pkgver=2.5
-pkgrel=1
+pkgver=2.6
+pkgrel=0
pkgdesc="The ASN.1 library used in GNUTLS"
url="http://www.gnu.org/software/gnutls/"
license="GPL3 LGPL"
@@ -22,4 +22,4 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="e60b863697713c3d6a59b1e8c6f9b0d1 libtasn1-2.5.tar.gz"
+md5sums="d410671e13038324336917ceed7470a5 libtasn1-2.6.tar.gz"
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index d1275f04d2..6086b38d9e 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcb
-pkgver=1.5
-pkgrel=1
+pkgver=1.6
+pkgrel=0
pkgdesc="X11 client-side library"
url="http://xcb.freedesktop.org/"
license="custom"
@@ -24,4 +24,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="d19c0ba6ba42ebccd3d62d8bb147b551 libxcb-1.5.tar.bz2"
+md5sums="cba9f6d1137ef00d9b326726d0bab6fd libxcb-1.6.tar.bz2"
diff --git a/main/mercurial/APKBUILD b/main/mercurial/APKBUILD
index 236b2758a0..dd7d265300 100644
--- a/main/mercurial/APKBUILD
+++ b/main/mercurial/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mercurial
-pkgver=1.5.1
-pkgrel=1
+pkgver=1.5.2
+pkgrel=0
pkgdesc="A scalable distributed SCM tool"
url="http://www.selenic.com/mercurial"
license="GPL"
@@ -29,4 +29,4 @@ package() {
install -Dm644 contrib/vim/HGAnnotate.vim \
"${vimpath}/syntax/HGAnnotate.vim" || return 1
}
-md5sums="22eac5602d777f9601e23700e641503f mercurial-1.5.1.tar.gz"
+md5sums="deafaaf017fc3c8a9deef39e566aec80 mercurial-1.5.2.tar.gz"
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index c2ab6e7906..43a33a6fd5 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -54,6 +54,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-cli $pkgname-pear
$pkgname-sysvmsg
$pkgname-sysvsem
$pkgname-sysvshm
+ $pkgname-xml
$pkgname-xmlrpc
$pkgname-xsl
$pkgname-zip
@@ -62,6 +63,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-cli $pkgname-pear
source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz
+ php-install-pear-xml.patch
zend_execute_API.c.patch
"
@@ -70,6 +72,9 @@ _extdir="/usr/lib/php/20090626"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # beat the pear installer into using xml.so
+ patch -p1 -i "$srcdir"/php-install-pear-xml.patch || return 1
+
# apply suhosin patch
gunzip -c ${srcdir}/suhosin-patch-${_suhosinver}.patch.gz \
| patch -p1 || return 1
@@ -95,7 +100,7 @@ build() {
--enable-sysvmsg=shared \
--enable-sysvsem=shared \
--enable-sysvshm=shared \
- --enable-xml \
+ --enable-xml=shared \
--enable-zip=shared \
--with-bz2=shared \
--with-curl=shared \
@@ -253,4 +258,5 @@ dev() {
md5sums="46f500816125202c48a458d0133254a4 php-5.3.2.tar.bz2
4647b05330862d6a1fc4469245cc6ade suhosin-patch-5.3.2-0.9.9.1.patch.gz
+5111e3be06d391f8772587c675240fab php-install-pear-xml.patch
55f9d24316a57e0c0f6b4b84791a1a17 zend_execute_API.c.patch"
diff --git a/main/php/php-install-pear-xml.patch b/main/php/php-install-pear-xml.patch
new file mode 100644
index 0000000000..f7a6fff58b
--- /dev/null
+++ b/main/php/php-install-pear-xml.patch
@@ -0,0 +1,15 @@
+--- ./pear/Makefile.frag.orig
++++ ./pear/Makefile.frag
+@@ -2,8 +2,11 @@
+
+ peardir=$(PEAR_INSTALLDIR)
+
++# help the built php to find xml extension so we can install pear
++PEAR_INSTALL_XML_FLAGS = -d extension_dir="$(top_builddir)/modules" -d extension=xml.so
++
+ # Skip all php.ini files altogether
+-PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0
++PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0 $(PEAR_INSTALL_XML_FLAGS)
+
+ WGET = `which wget 2>/dev/null`
+ FETCH = `which fetch 2>/dev/null`