aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/gcc/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index f452f7c35c..83243c2c28 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -243,6 +243,11 @@ build() {
s390x-*-*-*) _arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
esac
+ case "$CTARGET_ARCH" in
+ mips*) _hash_style_configure="--with-linker-hash-style=sysv" ;;
+ *) _hash_style_configure="--with-linker-hash-style=gnu" ;;
+ esac
+
case "$CTARGET_LIBC" in
musl)
# musl does not support mudflap, or libsanitizer
@@ -279,6 +284,7 @@ build() {
echo " libc_configure=$_libc_configure"
echo " cross_configure=$_cross_configure"
echo " bootstrap_configure=$_bootstrap_configure"
+ echo " hash_style_configure=$_hash_style_configure"
echo ""
mkdir -p "$_builddir"
@@ -306,7 +312,7 @@ build() {
$_cross_configure \
$_bootstrap_configure \
--with-system-zlib \
- --with-linker-hash-style=gnu
+ $_hash_style_configure
make
}