aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/patchwork/APKBUILD42
1 files changed, 10 insertions, 32 deletions
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
index a5e6c38343..1181c50865 100644
--- a/main/patchwork/APKBUILD
+++ b/main/patchwork/APKBUILD
@@ -8,9 +8,6 @@ url="https://github.com/getpatchwork/patchwork"
arch="noarch"
license="GPL"
depends="py-django py-django-registration git py-psycopg2"
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc $pkgname-uwsgi-apache2:apache2_wsgi $pkgname-uwsgi-nginx:nginx_wsgi $pkgname-mysql
$pkgname-postgresql pwclient:pwclient"
source="$pkgname-$pkgver.tar.gz::https://github.com/getpatchwork/$pkgname/archive/v$pkgver.tar.gz
@@ -19,33 +16,24 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/getpatchwork/$pkgname/archiv
nginx-uwsgi-patchwork-conf.ini
nginx-patchwork.conf"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
return 0
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/share/webapps/$pkgname
install -Dm644 COPYING \
- "$pkgdir"/usr/share/doc/$pkgname/COPYING || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/COPYING
rm -f COPYING
install -Dm644 patchwork/settings/production.example.py \
- "$pkgdir"/etc/$pkgname/production.py || return 1
+ "$pkgdir"/etc/$pkgname/production.py
mv * "$pkgdir"/usr/share/webapps/$pkgname
cd "$pkgdir"/usr/share/webapps/patchwork/patchwork/settings
- ln -sf /etc/patchwork/production.py || return 1
+ ln -sf /etc/patchwork/production.py
}
apache2_wsgi() {
@@ -54,7 +42,7 @@ apache2_wsgi() {
replaces="$pkgname-apache2-wsgi"
install_if="$pkgname=$pkgver-r$pkgrel apache2-mod-wsgi"
install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi.conf \
- "$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf || return 1
+ "$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf
}
nginx_wsgi() {
@@ -63,9 +51,9 @@ nginx_wsgi() {
replaces="$pkgname-nginx_wsgi"
install_if="nginx patchwork uwsgi"
install -Dm644 "$srcdir"/nginx-patchwork.conf \
- "$subpkgdir"/etc/nginx/conf.d/patchwork.conf || return 1
+ "$subpkgdir"/etc/nginx/conf.d/patchwork.conf
install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
- "$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini || return 1
+ "$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
}
mysql() {
@@ -84,19 +72,9 @@ pwclient() {
pkgdesc="command-line client for patchwork"
depends="python2"
install -Dm775 "$pkgdir"/usr/share/webapps/patchwork/patchwork/bin/pwclient \
- "$subpkgdir"/usr/bin/pwclient || return 1
+ "$subpkgdir"/usr/bin/pwclient
}
-md5sums="9d7cc6b90ba38dc48fce7cfe354daf48 patchwork-1.1.3.tar.gz
-c0bf2a78294773e6a5dc5fb5c9b525cf 0001-support-busybox-readlink.patch
-2dde450ee27a24ea4b0448b1331e7cc9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-f8807b30cceec56ec8428803a957537a nginx-uwsgi-patchwork-conf.ini
-1ada6412b1e22c084a08563bf75637d0 nginx-patchwork.conf"
-sha256sums="d96caa402d444203b57faaf25bfe00abdc484ae369d176fb6ddf7f4cf54d1a74 patchwork-1.1.3.tar.gz
-43159a12dbbd4161ae1476c38b5435517dbc7260a1e25aa6263038cc4c267b99 0001-support-busybox-readlink.patch
-499fc47ac715901fe0a5f5043f7ee722ab39e694451c70982830e1c728ea136d 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-d1d952c2c22d5d11256d17745fb9845d73ebef290982c671b48d1344b32431f6 nginx-uwsgi-patchwork-conf.ini
-1d869db2b0e11c8f0e57bc4e69ac6939cfaad759850ce072c6e349b2803633cc nginx-patchwork.conf"
sha512sums="e718ce942781c64e672c7ce9df4362277df418ba2adb61d8b512bf11ffd275d675f972703ceb301600e9b9914741f9b7f44229c1f1e5dec1470ce72b15a4598b patchwork-1.1.3.tar.gz
a5d4e24741b66092a39c1ef4fdc76dffa1ddf87a69544ab0c374fb0701b0f7340a62ead86835d9bb412df5713f3ea3c0218e9e2e0cd01d9a1aad9414a3cc75fa 0001-support-busybox-readlink.patch
12d1b184c6cb1d3f2c51adab6b60638e4869e055e677897bb66ee1a52312e77817bec543842324e2cbc2c226f3ab9d11c3782b5ef3a6f5f5712996cadbc6c9c9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch