aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/perl-date-manip/APKBUILD41
-rw-r--r--main/perl-date-manip/test.pl9
2 files changed, 0 insertions, 50 deletions
diff --git a/main/perl-date-manip/APKBUILD b/main/perl-date-manip/APKBUILD
deleted file mode 100644
index 5d3b940b73..0000000000
--- a/main/perl-date-manip/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=perl-date-manip
-_pkgreal=Date-Manip
-pkgver=6.76
-pkgrel=0
-pkgdesc="Date manipulation routines"
-url="http://search.cpan.org/dist/Date-Manip/"
-arch="noarch"
-license="GPL-1.0-or-later OR Artistic-1.0-Perl"
-cpandepends="perl-yaml-syck"
-cpanmakedepends="perl-test-inter"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-module-build"
-subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/$_pkgreal-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
-build() {
- cd "$builddir"
- make
-}
-
-check() {
- cd "$builddir"
- make test
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" pure_install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
-}
-
-sha512sums="dab6416e58ca5a032bd3e1a7d44578f5fad7ed6c2d9f1f8afdff6e04ecac13ceb035f533ab7f3cdb0875f7916166a51845f49cb8da40775846fb9b27b635e280 Date-Manip-6.76.tar.gz"
diff --git a/main/perl-date-manip/test.pl b/main/perl-date-manip/test.pl
deleted file mode 100644
index cd78aa14f8..0000000000
--- a/main/perl-date-manip/test.pl
+++ /dev/null
@@ -1,9 +0,0 @@
-use Date::Manip;
-
-$dmt = new Date::Manip::TZ;
-$obj = $dmt->base();
-$dmt->config("forcedate","now,America/New_York");
-
-print $obj->days_since_1BC([1,1,1]),"\n";
-print $obj->days_since_1BC([2,1,1]),"\n";
-