aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/libressl/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 4cc9b26601..2c550639ac 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -12,7 +12,7 @@
pkgname=libressl
pkgver=2.7.5
_namever=${pkgname}${pkgver%.*}
-pkgrel=0
+pkgrel=1
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
@@ -64,11 +64,20 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd "$pkgdir"
+
# /usr/bin/openssl will be replaced with openssl's binary. We provide
# a /usr/bin/libressl binary in case something needs it and a
# symlink so /usr/bin/openssl exists during upgrade
- mv "$pkgdir"/usr/bin/openssl "$pkgdir"/usr/bin/libressl
- ln -s libressl "$pkgdir"/usr/bin/openssl
+ mv usr/bin/openssl usr/bin/libressl
+ ln -s libressl usr/bin/openssl
+
+ # Provided by ca-certificates-cacerts
+ rm etc/ssl/cert.pem
+ rmdir etc/ssl/certs
+
+ # Provided by openssl's libcrypto1.1
+ rm etc/ssl/openssl.cnf
}
_libs() {