aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/consolekit/APKBUILD58
-rw-r--r--main/consolekit2/0001-busybox-reboot-and-poweroff-support.patch (renamed from main/consolekit/0001-busybox-reboot-and-poweroff-support.patch)1
-rw-r--r--main/consolekit2/APKBUILD49
-rw-r--r--main/consolekit2/ac_disable_static.patch13
-rw-r--r--main/consolekit2/pam-foreground-compat.ck (renamed from main/consolekit/pam-foreground-compat.ck)8
5 files changed, 66 insertions, 63 deletions
diff --git a/main/consolekit/APKBUILD b/main/consolekit/APKBUILD
deleted file mode 100644
index 2a55f647d6..0000000000
--- a/main/consolekit/APKBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=consolekit
-pkgver=0.4.6
-pkgrel=2
-pkgdesc="Framework for defining and tracking users, login sessions, and seats"
-url="http://www.freedesktop.org/wiki/Software/ConsoleKit"
-arch="all"
-license="GPL2+"
-depends=""
-makedepends="polkit-dev zlib-dev libx11-dev dbus-glib-dev linux-headers"
-depends_dev="dbus-dev"
-install=""
-subpackages="$pkgname-dev"
-source="http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-$pkgver.tar.xz
- 0001-busybox-reboot-and-poweroff-support.patch
- pam-foreground-compat.ck
- "
-
-_builddir="$srcdir"/ConsoleKit-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -m 755 "$srcdir"/pam-foreground-compat.ck \
- "$pkgdir"/usr/lib/ConsoleKit/run-session.d/
-}
-
-md5sums="611792b4d616253a5bdec9175f8b7678 ConsoleKit-0.4.6.tar.xz
-acc4f44190cd677f95fd529d528c9cef 0001-busybox-reboot-and-poweroff-support.patch
-d75ed3438dab01552304c06fd9a967b1 pam-foreground-compat.ck"
-sha256sums="b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c ConsoleKit-0.4.6.tar.xz
-acbc1e1fa9530404b89f4eb57ebea8a55fb574724af5c635593b16d50ae55e56 0001-busybox-reboot-and-poweroff-support.patch
-8e197a732d676e12e8fa918c0587522d432b7756987273de2e940a625a38ee8a pam-foreground-compat.ck"
-sha512sums="54955e3e83778a9216846104da8762fd50a37190e209127dd5d211e2227da617e14f6f5c1359905396d299656e526d14e1187b28eaff7d0ae1d7563dc8d9b46d ConsoleKit-0.4.6.tar.xz
-d6ee14662ffc64407cddef95d0c4d22189b8879fc03e6583ffa5201fe65f73fa928cb33d3f9dfd7ba942113fdd39cb816f1c7b4c6500ea5f0cfcc2e35b2e248f 0001-busybox-reboot-and-poweroff-support.patch
-46e98e356e4e4f2f792147dce940fc2310b71bede28e58bc2d2ee74f4fcca20fa74dc4fef17ed6cb8c2e4c8d0f38710594fd394302b3fd469bbdf7d44ab4caae pam-foreground-compat.ck"
diff --git a/main/consolekit/0001-busybox-reboot-and-poweroff-support.patch b/main/consolekit2/0001-busybox-reboot-and-poweroff-support.patch
index 7fa0e35759..2db9f032bd 100644
--- a/main/consolekit/0001-busybox-reboot-and-poweroff-support.patch
+++ b/main/consolekit2/0001-busybox-reboot-and-poweroff-support.patch
@@ -38,4 +38,3 @@ index e26bca3..a0be3ac 100755
fi
--
1.7.4.2
-
diff --git a/main/consolekit2/APKBUILD b/main/consolekit2/APKBUILD
new file mode 100644
index 0000000000..669c215d46
--- /dev/null
+++ b/main/consolekit2/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgbase=ConsoleKit2
+pkgname=consolekit2
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="A framework for defining and tracking users, login sessions, and seats"
+provides="consolekit=$pkgver"
+replaces=consolekit
+arch=all
+url="https://consolekit2.github.io/ConsoleKit2"
+license=GPL2
+depends="polkit eudev"
+makedepends="git automake autoconf gettext-dev glib-dev zlib-dev libxslt-dev
+ polkit-dev eudev-dev libdrm-dev libnih-dev libtool
+ xorg-server-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz
+ ac_disable_static.patch
+ 0001-busybox-reboot-and-poweroff-support.patch
+ pam-foreground-compat.ck"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+builddir="$srcdir"/$pkgbase-$pkgver
+
+prepare() {
+ default_prepare
+
+ cd "$srcdir"/$pkgbase-$pkgver
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$srcdir"/$pkgbase-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -m 755 "$srcdir"/pam-foreground-compat.ck \
+ "$pkgdir"/usr/lib/ConsoleKit/run-session.d/
+}
+sha512sums="30f2ceec14044669f40676e9b17513874350e2b70f0a918be934f7e64309c8595dbec4ac0937044c98dda51eb97c99443dc9d1de33f08365d72da8600296ad78 consolekit2-1.2.0.tar.gz
+0f628fd1589b1790ad9adcb2278de504b75cc6b4ec7284a1cbda44ebd34b9966014989f47f343cb936d8503acc4eeec43ddff07cb11f55388e47256b8420e2e8 ac_disable_static.patch
+ec0c88e640afac0561c84131d63fa8c9e2e29611b789ae5c163cd11465b22017602d88dc853866624f57bce2ee466ab63af075d083a9ba6e87327ad8d0a0769f 0001-busybox-reboot-and-poweroff-support.patch
+3b114fbbe74cfba0bfd4dad0eb1b85d08b4979a998980c1cbcd7f44b8a16b0ceca224680d4f4a1644cd24698f8817e5e8bdfcdc4ead87a122d0e323142f47910 pam-foreground-compat.ck"
diff --git a/main/consolekit2/ac_disable_static.patch b/main/consolekit2/ac_disable_static.patch
new file mode 100644
index 0000000000..38d6f12ac1
--- /dev/null
+++ b/main/consolekit2/ac_disable_static.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 071a0d8..7469697 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,6 @@ AC_SEARCH_LIBS([strerror],[cposix])
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_HEADER_STDC
+-AC_DISABLE_STATIC
+-LT_INIT
++LT_INIT([disable-static])
+ AC_HEADER_STDC
+ AC_FUNC_FORK
diff --git a/main/consolekit/pam-foreground-compat.ck b/main/consolekit2/pam-foreground-compat.ck
index ce221c9749..c9255503c4 100644
--- a/main/consolekit/pam-foreground-compat.ck
+++ b/main/consolekit2/pam-foreground-compat.ck
@@ -7,11 +7,11 @@ TAGDIR=/var/run/console
TAGFILE="$TAGDIR/`getent passwd $CK_SESSION_USER_UID | cut -f 1 -d:`"
if [ "$1" = "session_added" ]; then
- mkdir -p "$TAGDIR"
- echo "$CK_SESSION_ID" >> "$TAGFILE"
+ mkdir -p "$TAGDIR"
+ echo "$CK_SESSION_ID" >> "$TAGFILE"
fi
if [ "$1" = "session_removed" ] && [ -e "$TAGFILE" ]; then
- sed -i "\%^$CK_SESSION_ID\$%d" "$TAGFILE"
- [ -s "$TAGFILE" ] || rm -f "$TAGFILE"
+ sed -i "\%^$CK_SESSION_ID\$%d" "$TAGFILE"
+ [ -s "$TAGFILE" ] || rm -f "$TAGFILE"
fi