aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/py3-asn1crypto/APKBUILD35
1 files changed, 9 insertions, 26 deletions
diff --git a/main/py3-asn1crypto/APKBUILD b/main/py3-asn1crypto/APKBUILD
index 756af8f59f..145ef1787a 100644
--- a/main/py3-asn1crypto/APKBUILD
+++ b/main/py3-asn1crypto/APKBUILD
@@ -1,51 +1,34 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=py-asn1crypto
+pkgname=py3-asn1crypto
_pkgname=asn1crypto
pkgver=0.24.0
-pkgrel=1
-pkgdesc="Python ASN.1 library with a focus on performance and a pythonic API"
+pkgrel=2
+pkgdesc="Python3 ASN.1 library with a focus on performance and a pythonic API"
url="https://github.com/wbond/asn1crypto"
arch="noarch"
license="MIT"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3"
+makedepends="py3-setuptools"
source="$_pkgname-$pkgver.tar.gz::https://github.com/wbond/asn1crypto/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-asn1crypto" # Backwards compatibility
+provides="py-asn1crypto=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
cd "$builddir"
- python2 run.py tests
python3 run.py tests
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="426cc380903b4dd7aadd7b831e3a11ee3442c961a33b856d4aa8d9060e829f2e0ad905a60c4d6504569718fe2cee01d9be31628c89ef030bc34281e381c898e8 asn1crypto-0.24.0.tar.gz"