aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/py3-pathlib2/APKBUILD35
1 files changed, 8 insertions, 27 deletions
diff --git a/main/py3-pathlib2/APKBUILD b/main/py3-pathlib2/APKBUILD
index 7d93732eaa..391df5fa50 100644
--- a/main/py3-pathlib2/APKBUILD
+++ b/main/py3-pathlib2/APKBUILD
@@ -1,52 +1,33 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=py-pathlib2
+pkgname=py3-pathlib2
pkgver=2.3.4
-pkgrel=0
+pkgrel=1
pkgdesc="Fork of pathlib aiming to support the full stdlib Python API"
url="https://github.com/mcmtroffaes/pathlib2"
arch="noarch"
license="MIT"
+depends="python3 py3-six py3-scandir"
+makedepends="py3-setuptools"
source="pathlib2-$pkgver.tar.gz::https://github.com/mcmtroffaes/pathlib2/archive/$pkgver.tar.gz"
builddir="$srcdir/pathlib2-$pkgver"
-depends="py-six py-scandir"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+
+replaces="py-pathlib2" # Backwards compatibility
+provides="py-pathlib2=$pkgver-r$pkgrel" # Backwards compatibility
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="79b37a97037ba9ca2b315c7c4ff06e8b9b492d4f5d5cfe33e8b4cae533bf2314d27edb1a21f83791d82a1761df6a97bc07376cbff61e29e4bf43552daab499a0 pathlib2-2.3.4.tar.gz"