aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/luajit/APKBUILD8
-rw-r--r--main/luajit/enable-support-for-ppc64le.patch2
2 files changed, 5 insertions, 5 deletions
diff --git a/main/luajit/APKBUILD b/main/luajit/APKBUILD
index b554116c4b..eb32b7b090 100644
--- a/main/luajit/APKBUILD
+++ b/main/luajit/APKBUILD
@@ -2,9 +2,9 @@
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=luajit
-pkgver=2.1.0_beta2
+pkgver=2.1.0_beta3
_realver=${pkgver/_/-}
-pkgrel=4
+pkgrel=0
pkgdesc='Just-in-time compiler and replacement for Lua 5.1'
url='http://luajit.org'
arch="all !s390x"
@@ -35,5 +35,5 @@ package() {
$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT
}
-sha512sums="ef04db5bee66a6e24da8d488df2c035c9593792dca4cb49955d673281a7c7b00ab40f4a63e699959461da7fb0732cf81ec46808c33b66ae1eaca4ef94d0b61e3 LuaJIT-2.1.0-beta2.tar.gz
-d48d74c856aed035d17f8355178cab4c17b5fed97d0a218fee7293fbb5c262b564cbc4ecf2e7c8558186371ae57df6f932e0313ed0453552ef99052f82876241 enable-support-for-ppc64le.patch"
+sha512sums="c44e967a0f671ed32b55aee810bc8b3b63737a2d7363b8984ae1949b24f98dbb3f9be7c1e10239fdeb96a3e3c836f606342cbd61838cf9bcadb077443eb5bc12 LuaJIT-2.1.0-beta3.tar.gz
+c2b1a39fe19dfe1817811015ef1fea24b0966ff791fcbde1090527331c2b9ceab9b923960c01cfb8aa81bab40aa437eb0f285385378e7eaa83016abf36beae27 enable-support-for-ppc64le.patch"
diff --git a/main/luajit/enable-support-for-ppc64le.patch b/main/luajit/enable-support-for-ppc64le.patch
index 0cd000b201..f6a46c37c9 100644
--- a/main/luajit/enable-support-for-ppc64le.patch
+++ b/main/luajit/enable-support-for-ppc64le.patch
@@ -270,7 +270,7 @@ index 9986768..7a68e2a 100644
/*
-** Definitions for PPC CPUs.
+** Definitions for PPC/PPC64 CPUs.
- ** Copyright (C) 2005-2016 Mike Pall. See Copyright Notice in luajit.h
+ ** Copyright (C) 2005-2017 Mike Pall. See Copyright Notice in luajit.h
*/
@@ -131,6 +131,8 @@ static LJ_AINLINE uint32_t *exitstub_trace_addr_(uint32_t *p, uint32_t exitno)