aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/imagemagick/APKBUILD138
-rw-r--r--main/imagemagick/disable-avaraging-tests.patch26
2 files changed, 0 insertions, 164 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
deleted file mode 100644
index 4486df8487..0000000000
--- a/main/imagemagick/APKBUILD
+++ /dev/null
@@ -1,138 +0,0 @@
-# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=imagemagick
-_pkgname=ImageMagick
-pkgver=7.0.8.64
-pkgrel=0
-_pkgver=${pkgver%.*}-${pkgver##*.}
-_abiver=7
-pkgdesc="Collection of tools and libraries for many image formats"
-url="https://www.imagemagick.org/"
-arch="all"
-license="ImageMagick"
-options="libtool !checkroot"
-makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
- perl-dev ghostscript-dev libwebp-dev libtool tiff-dev lcms2-dev
- libwebp-dev libxml2-dev librsvg-dev libx11-dev libxext-dev chrpath
- libheif-dev"
-checkdepends="freetype fontconfig ghostscript ghostscript-fonts lcms2 graphviz"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs $pkgname-perlmagick:_perlmagick $pkgname-perlmagick-doc:_perlmagick_doc"
-source="$_pkgname-$_pkgver.tar.gz::https://github.com/ImageMagick/ImageMagick/archive/$_pkgver.tar.gz
- disable-avaraging-tests.patch"
-builddir="$srcdir/$_pkgname-$_pkgver"
-
-# secfixes:
-# 6.9.10.56-r0:
-# - CVE-2019-13454
-# 6.9.10.53-r0:
-# - CVE-2019-13391
-# - CVE-2019-13311
-# - CVE-2019-13310
-# - CVE-2019-13309
-# - CVE-2019-13308
-# - CVE-2019-13307
-# - CVE-2019-13306
-# - CVE-2019-13305
-# - CVE-2019-13304
-# - CVE-2019-13303
-# - CVE-2019-13302
-# - CVE-2019-13301
-# - CVE-2019-13300
-# - CVE-2019-13299
-# - CVE-2019-13298
-# - CVE-2019-13297
-# - CVE-2019-13296
-# - CVE-2019-13295
-# - CVE-2019-13137
-# - CVE-2019-13136
-# - CVE-2019-13135
-# - CVE-2019-13134
-# - CVE-2019-13133
-# 7.0.8.44-r0:
-# - CVE-2019-11598
-# - CVE-2019-11597
-# - CVE-2019-11472
-# 7.0.8.38-r0:
-# - CVE-2019-9956
-# - CVE-2019-10649
-# - CVE-2019-10650
-
-build() {
- cd "$builddir"
- # fix doc dir, Gentoo bug 91911
- sed -i -e \
- 's:DOCUMENTATION_PATH="${DATA_DIR}/doc/${DOCUMENTATION_RELATIVE_PATH}":DOCUMENTATION_PATH="/usr/share/doc/imagemagick":g' \
- configure
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-static \
- --disable-openmp \
- --with-threads \
- --with-x \
- --with-tiff \
- --with-png \
- --with-webp \
- --with-rsvg \
- --with-gslib \
- --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-heic \
- --with-modules \
- --with-xml \
- --with-perl \
- --with-perl-options="PREFIX=/usr INSTALLDIRS=vendor" \
- $_pic
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
- if ! [ -e "$pkgdir"/usr/lib/libMagickCore-$_abiver.Q16HDRI.so ]; then
- error "Has ABI verision changed? (current is $_abiver)"
- return 1
- fi
-
- # we cannot let abuild delete the *.la files due to we need *.la
- # for the modules
- rm "$pkgdir"/usr/lib/*.la
-
- find "$pkgdir" -name '.packlist' -o -name 'perllocal.pod' \
- -o -name '*.bs' -delete
-}
-
-_cxx() {
- pkgdesc="ImageMagick Magick++ library (C++ bindings)"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libMagick++*.so.* "$subpkgdir"/usr/lib/
-}
-
-_perlmagick() {
- pkgdesc="PerlMagick Perl Modules for ImageMagick"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/perl5 "$subpkgdir"/usr/lib/
- # Strip all the rpath that include /home
- scanelf --recursive --rpath "$subpkgdir" | awk '/home/{print $3;}' | xargs chrpath -d
-# chrpath -d "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Image/Magick/Q16HDRI/Q16HDRI.so
-# chrpath -d "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Image/Magick/Magick.so
-}
-
-_perlmagick_doc() {
- pkgdesc="PerlMagick Perl Module Documentation for ImageMagick"
- mkdir -p "$subpkgdir"
- cd "$builddir"/PerlMagick
- make -j1 DESTDIR="$subpkgdir" doc_vendor_install
-}
-
-sha512sums="6fa1a3ee272eee05fc6d80941adee6396c637705dde928e895826eac9cb6e5978e981d71a3102c0961fe3a118c0bd1b3bab6a80f6da264113012aa036ec5633e ImageMagick-7.0.8-64.tar.gz
-58afb2da075a6208b6a990ff297b3a827d260687c3355198a8b4d987e1596c0b0cd78aff6f0be0e1896e537fbe44a3d467473183f5f149664ea6e6fb3d3291a9 disable-avaraging-tests.patch"
diff --git a/main/imagemagick/disable-avaraging-tests.patch b/main/imagemagick/disable-avaraging-tests.patch
deleted file mode 100644
index 8e715f81e6..0000000000
--- a/main/imagemagick/disable-avaraging-tests.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-The avaraging tests seems to be flaky due to rounding errors. Test fails on
-x86 and s390x
-
-https://github.com/ImageMagick/ImageMagick/issues/1576#issuecomment-494595404
-
-diff --git a/Magick++/tests/tests.tap b/Magick++/tests/tests.tap
-index b5c15ff..bb83980 100755
---- a/Magick++/tests/tests.tap
-+++ b/Magick++/tests/tests.tap
-@@ -8,14 +8,14 @@
- #
- subdir=Magick++/tests
- . ./common.shi
--echo "1..13"
-+echo "1..12"
-
- SRCDIR=${top_srcdir}/${subdir}/
- export SRCDIR
-
- cd ${subdir} || exit 1
-
--for mytest in appendImages attributes averageImages coalesceImages coderInfo color colorHistogram exceptions geometry montageImages morphImages readWriteBlob readWriteImages
-+for mytest in appendImages attributes coalesceImages coderInfo color colorHistogram exceptions geometry montageImages morphImages readWriteBlob readWriteImages
- do
- ./${mytest} && echo "ok" || echo "not ok"
- done