aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/x264/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index c24cb67ff8..6ee948842b 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -15,7 +15,13 @@ _builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
build() {
cd "$_builddir"
local _asmopts=
- [ "$CARCH" = "x86" ] && _asmopts="--disable-asm"
+
+ case "$CARCH" in
+ # x86 assembly contains TEXTRELs
+ # arm neon assembly contains TEXTRELs
+ x86 | arm*) _asmopts="--disable-asm"
+ esac
+
# note: not autotools
./configure \
--host=$CHOST \