aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/chromium/APKBUILD43
-rw-r--r--main/chromium/chromium-hotwording-2403.patch147
-rw-r--r--main/chromium/chromium-system-libvpx-r0.patch10
-rw-r--r--main/chromium/issue1107683002_20001_30001.patch14
-rw-r--r--main/chromium/musl-fixes.patch20
-rw-r--r--main/chromium/no-mallinfo.patch31
6 files changed, 67 insertions, 198 deletions
diff --git a/main/chromium/APKBUILD b/main/chromium/APKBUILD
index d9773cf05c..7740b529e4 100644
--- a/main/chromium/APKBUILD
+++ b/main/chromium/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=chromium
-pkgver=43.0.2357.134
+pkgver=44.0.2403.107
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
@@ -16,7 +16,8 @@ depends_dev="alsa-lib-dev libevent-dev libpng-dev jpeg-dev cairo-dev cups-dev
gnutls-dev mesa-dev libxcursor-dev libxcomposite-dev krb5-dev
libxrandr-dev libxscrnsaver-dev pciutils-dev eudev-dev libexif-dev
hwdata-usb ninja libbsd-dev harfbuzz-dev snappy-dev
- bsd-compat-headers openssl-dev libre2-dev jsoncpp-dev minizip-dev"
+ bsd-compat-headers openssl-dev libre2-dev jsoncpp-dev minizip-dev
+ linux-headers"
makedepends="$depends_dev xdg-utils yasm gperf bison flex perl python bash
paxmark findutils"
install=""
@@ -36,11 +37,8 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
no-getcontext.patch
musl-sandbox.patch
- chromium-hotwording-2403.patch
- chromium-system-libvpx-r0.patch
chromium-system-jinja-r7.patch
chromium-widevine.patch
- issue1107683002_20001_30001.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -156,7 +154,7 @@ package() {
cd "$_builddir"
local bin pak
- for bin in chrome libffmpegsumo.so natives_blob.bin snapshot_blob.bin; do
+ for bin in chrome natives_blob.bin snapshot_blob.bin; do
install -Dm755 out/Release/$bin \
"$pkgdir"/usr/lib/$pkgname/$bin || return 1
done
@@ -212,54 +210,45 @@ chromedriver() {
"$subpkgdir"/usr/lib/$pkgname/chromedriver || return 1
}
-md5sums="be03713aace91cd6ca539427174ba7e4 chromium-43.0.2357.134.tar.xz
+md5sums="4c89a0d68ab66594de43733478ffe524 chromium-44.0.2403.107.tar.xz
b6d015c1da85aa65ee21bc974c7fc7d2 chromium-launcher.sh
c5aa73a87d4b88cce9f1a680ca691bb6 chromium.conf
2962ac6259e39a797d441daf43aa49c9 chromium.desktop
2d2ee5f22d65c756871301b4a407f4ca google-api.keys
96277e7ddc26c8bdd50fb63eff2f4ce0 gcc5-fixes.patch
-1b6076a7fac1d056fd6064f5b1b98320 musl-fixes.patch
+4d51f367a9220703f5f7dd962388b5a7 musl-fixes.patch
00ae59dd9d09c60a116fd0133f9f3a60 no-execinfo.patch
af047840f31e99aa36be04edc3482afd resolver.patch
-a11a60155a9faf6ca648aaa06c81f29e no-mallinfo.patch
+63cb370a0a1db204dece7c611c483395 no-mallinfo.patch
2c8de771a7c0e5e0e9fc68fa978785f7 no-getcontext.patch
4f22f0d05448c49d6501386523a081ba musl-sandbox.patch
-2b7291195c467f8135473e543c1c7dad chromium-hotwording-2403.patch
-9a73cf075dc321dfe781f5bed4920d6c chromium-system-libvpx-r0.patch
97b1578585ab600ed9adef4f341ccd80 chromium-system-jinja-r7.patch
-de717d6430532f34fe161035dfdafcdf chromium-widevine.patch
-eb577b0daae37843d70844020d46f9d5 issue1107683002_20001_30001.patch"
-sha256sums="d3a1bbe3e1445dfcf5ef4aff4b11a8f3770436c8b8954b7cc5fee5416f117659 chromium-43.0.2357.134.tar.xz
+de717d6430532f34fe161035dfdafcdf chromium-widevine.patch"
+sha256sums="d0634ffbe4f158010852fde3ee32aaf7bdf200932573fdf57328dd9ba5983d71 chromium-44.0.2403.107.tar.xz
89f1eb19d1ed998a190045ea173959f01faee3490d58a6a34ca3fe21228e569f chromium-launcher.sh
b466559340a36998354a0577325fe533d9e6b74c24a15b7599671171506bf128 chromium.conf
3ae90cea7503d0039de53448ed112b9bc0cb5a09f6b0045506eb777fc23517e5 chromium.desktop
267ba8ff50574e51d2582c4fca9b9e14f7225c1fa064d135cbceff9cef2324ac google-api.keys
ee32d8a89cc51cb71a8d4aa82b196b145f43a2fc3ba9687f9c06c053601d5fe7 gcc5-fixes.patch
-ac38e2d1238b7062ee8c99ff7772477fa2d5328a750eab47553687e3782dc7a9 musl-fixes.patch
+55150c9f0671789b998d8f858e7c8640e30331b92912dea0a19458c9d0c3f31c musl-fixes.patch
505a55c28e971e067f189e3a1ce697d711cec82a765d81f78eb49ec1f6df56cf no-execinfo.patch
f16c63d4188fe56732dc6760307795ba4059452c4cf3de1460cbcb2616011511 resolver.patch
-3e732ba5bbe324932a06a782bae655003089f5dc52a7bb2b790aa4837e20be8e no-mallinfo.patch
+a3687b773372b2f259929f39ccf9e8a79709a308e2630e352c30fdcf0df51c8a no-mallinfo.patch
ea79f9a46116c8b56bbc69d226abd9252e4ae4d946ca695203f2298279cc2211 no-getcontext.patch
20fcb99022f3a737dceea7349da61e12a85834c0ab65a02009b6f56acb8b0f07 musl-sandbox.patch
-7d20f05bbd2b9ba363b28ed591cd0c770b4d7365a7ca9d20b5f6a268f6af2122 chromium-hotwording-2403.patch
-06b26f3459e2f60866eb28803f129c59e064b082eae76126de60463706739f8c chromium-system-libvpx-r0.patch
872f5a38d8263b14308bb117828496a4093d0e6ad755d39d2c5e6857314fe071 chromium-system-jinja-r7.patch
-1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch
-f634567b717568ca2e06b2e10862f31c6cc5a86e09214bc771a94030167ed222 issue1107683002_20001_30001.patch"
-sha512sums="c431d1866c4ff36be8dd572d96631aa85339edd468a0598d1516785450ceac5c40595b2d14783b6424fe731aaf3eb5eb6b0134bbc025f85044fc853283a9a618 chromium-43.0.2357.134.tar.xz
+1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch"
+sha512sums="eab60b3f7e1430bec65d01a5d9428565dea0ffc25cd42646a81a30174998c1a92d7de91c9381c1d9462017f28fe9b0214c542ba64a5690069d7af1b5d277d8c6 chromium-44.0.2403.107.tar.xz
b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
e2390cdeb2a75aad51d5da07819e1375fcf2092535eaa86545b9bc0160eff9e3981f946029ed8fc337df4c56a8b8cc7945821d2636b09e320dea2c8884022a59 gcc5-fixes.patch
-febb6a204bcffda8dc3d80e75563710745e383cb30e460db5d8c5ded3d40f8a872461719283260f573be378e085924ddf3af000b0a50b519fafd9f6fc392920e musl-fixes.patch
+47d2fa2e3cad35e6eca5de9ffad1eacdce7c82e4da4579aa08e7fde0fb5690b9925c8f925b484f012ce1eaf22b18350e2fbdd5f38301c45b390da4393158bf79 musl-fixes.patch
4f756d3e404033f7a36b38266176b7302f7e2a2e78c9f8b8d362a53a3dbdc675cdaa581393a70c23a29135b34566cf4109513cb13a289dc111bbce65ec065ebd no-execinfo.patch
987f18d37824676e5d874a6fde1099bcc558920e7781de5f34e612411013e4fac9ca421a3cce1ed5f82401c4d54212b6f47a0a856892a78543b8e400a4bb0489 resolver.patch
-511a3852d6172c14c651c316f1f874cfd23be0fde1c4285565dfead02e5865a1b240c40e270c940a23c55e2d3f2cfecbf3b5477bf9e6d3cf920d7c60331dc3c3 no-mallinfo.patch
+5d6efa5800ec9d3680efa7946ecbadd4b8a63e56d4f94274a0afa61119f10aad6e4af0898b8724041869fade85a86980eabb94cbf120c8847a1386b33f0da55c no-mallinfo.patch
42d9a6ebea2d95cdc169b921cc1a1b846cf500997059fd3084de09e21f00b63b76e60c6124f4af247d402ff5ca3f4bf8867a6f2c78198c05b4273ca01fb29241 no-getcontext.patch
cc61407bae55523fd3d0b43be7cf827cd6a648314a81f8d78f830e60cb215ede6c585d8755e9c870bb98955a4d3679205cbefde6f4efcb0e48469169167823eb musl-sandbox.patch
-38dcbae0d9bc63c044d50bd395692007642af705e1bbb9b704f3f349a48e45ca2b7f8495dbafbb4333b8bdb84ac53e5611eba4fe3d4fc7e841b319b4d744c324 chromium-hotwording-2403.patch
-fe5801b63e7cb58c4653e6f4542de070cb5bf88e0d99fdd0bb7b45ba928be065ebda41fb1f5fa32f4a55d321b8765df53a977bf2d1418b030846a9e2b2fd1c1d chromium-system-libvpx-r0.patch
10bcc6a467b6766d13b5e41e7b7dcdbd62de7c04daad16c83037e88043032a0c118627029f91ef8a2a57faaaebc8b6f4ee16e8d1fecb5921d0d49efd60a27863 chromium-system-jinja-r7.patch
-4a11b46afa8ce84bd23a8c506301b5848ee4291a764f3aed282b8a98706ece16cf9346dec6cc71b1e17812b15f43a5cbc7bc6d38ed4dcc88c12d6fcb03bd9295 chromium-widevine.patch
-c2015fd83c1cb659c275d18cc457882c97e53d7a4649effe1d7107325313f50eaabd70e5b562d619fa51b980481b8daa0a15277dc9bf2472941293a8c444ddf2 issue1107683002_20001_30001.patch"
+4a11b46afa8ce84bd23a8c506301b5848ee4291a764f3aed282b8a98706ece16cf9346dec6cc71b1e17812b15f43a5cbc7bc6d38ed4dcc88c12d6fcb03bd9295 chromium-widevine.patch"
diff --git a/main/chromium/chromium-hotwording-2403.patch b/main/chromium/chromium-hotwording-2403.patch
deleted file mode 100644
index a3904ad030..0000000000
--- a/main/chromium/chromium-hotwording-2403.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-From c2a0c6df7d468da9864c56f2099aa947b07e2535 Mon Sep 17 00:00:00 2001
-From: amistry <amistry@chromium.org>
-Date: Tue, 9 Jun 2015 12:18:39 -0700
-Subject: [PATCH] Add build flag to disable hotwording.
-
-Hotwording downloads a shared module from the web store containing a NaCl module. There is a desire to build and distribute Chromium without this happening. This change adds an "enable_hotwording" build flag that is enabled by default, but can be disabled at compile time.
-
-BUG=491435
-
-Review URL: https://codereview.chromium.org/1160243004
-
-Cr-Commit-Position: refs/heads/master@{#333548}
-
-Conflicts:
- chrome/browser/search/hotword_service.cc
----
- build/common.gypi | 4 ++++
- chrome/browser/BUILD.gn | 9 +++++++++
- chrome/browser/search/hotword_service.cc | 4 ++++
- chrome/browser/search/hotword_service_unittest.cc | 4 ++++
- chrome/chrome_browser.gypi | 3 +++
- 5 files changed, 24 insertions(+)
-
-diff --git a/build/common.gypi b/build/common.gypi
-index 339cc75..ddb075c 100644
---- a/build/common.gypi
-+++ b/build/common.gypi
-@@ -381,6 +381,9 @@
- # Web speech is enabled by default. Set to 0 to disable.
- 'enable_web_speech%': 1,
-
-+ # 'Ok Google' hotwording is enabled by default. Set to 0 to disable.
-+ 'enable_hotwording%': 1,
-+
- # Notifications are compiled in by default. Set to 0 to disable.
- 'notifications%' : 1,
-
-@@ -1134,6 +1137,7 @@
- 'configuration_policy%': '<(configuration_policy)',
- 'safe_browsing%': '<(safe_browsing)',
- 'enable_web_speech%': '<(enable_web_speech)',
-+ 'enable_hotwording%': '<(enable_hotwording)',
- 'notifications%': '<(notifications)',
- 'clang_use_chrome_plugins%': '<(clang_use_chrome_plugins)',
- 'mac_want_real_dsym%': '<(mac_want_real_dsym)',
-diff --git a/chrome/browser/BUILD.gn b/chrome/browser/BUILD.gn
-index 5152d83..6ccb079 100644
---- a/chrome/browser/BUILD.gn
-+++ b/chrome/browser/BUILD.gn
-@@ -18,6 +18,11 @@ if (is_desktop_linux) {
- import("//build/config/linux/pkg_config.gni")
- }
-
-+declare_args() {
-+ # 'Ok Google' hotwording is enabled.
-+ enable_hotwording = true
-+}
-+
- about_credits_file = "$target_gen_dir/about_credits.html"
- additional_modules_list_file =
- "$root_gen_dir/chrome/browser/internal/additional_modules_list.txt"
-@@ -455,6 +460,10 @@ source_set("browser") {
- }
- }
-
-+ if (enable_hotwording) {
-+ defines += [ "ENABLE_HOTWORDING" ]
-+ }
-+
- if (is_linux) {
- deps += [
- "//device/media_transfer_protocol",
-diff --git a/chrome/browser/search/hotword_service.cc b/chrome/browser/search/hotword_service.cc
-index 0cf3c60..e93789b 100644
---- a/chrome/browser/search/hotword_service.cc
-+++ b/chrome/browser/search/hotword_service.cc
-@@ -642,6 +642,7 @@ bool HotwordService::IsServiceAvailable() {
- }
-
- bool HotwordService::IsHotwordAllowed() {
-+#if defined(ENABLE_HOTWORDING)
- std::string group = base::FieldTrialList::FindFullName(
- hotword_internal::kHotwordFieldTrialName);
- // Allow hotwording by default, and only disable if the field trial has been
-@@ -650,6 +651,9 @@ bool HotwordService::IsHotwordAllowed() {
- return false;
-
- return DoesHotwordSupportLanguage(profile_);
-+#else
-+ return false;
-+#endif
- }
-
- bool HotwordService::IsOptedIntoAudioLogging() {
-diff --git a/chrome/browser/search/hotword_service_unittest.cc b/chrome/browser/search/hotword_service_unittest.cc
-index a3aef47..b0b5927 100644
---- a/chrome/browser/search/hotword_service_unittest.cc
-+++ b/chrome/browser/search/hotword_service_unittest.cc
-@@ -216,6 +216,7 @@ TEST_P(HotwordServiceTest, IsHotwordAllowedInvalidFieldTrial) {
- }
-
- TEST_P(HotwordServiceTest, IsHotwordAllowedLocale) {
-+#if defined(ENABLE_HOTWORDING)
- TestingProfile::Builder profile_builder;
- scoped_ptr<TestingProfile> profile = profile_builder.Build();
-
-@@ -246,6 +247,7 @@ TEST_P(HotwordServiceTest, IsHotwordAllowedLocale) {
- Profile* otr_profile = profile->GetOffTheRecordProfile();
- SetApplicationLocale(otr_profile, "en");
- EXPECT_FALSE(HotwordServiceFactory::IsHotwordAllowed(otr_profile));
-+#endif // defined(ENABLE_HOTWORDING)
- }
-
- TEST_P(HotwordServiceTest, ShouldReinstallExtension) {
-@@ -302,6 +304,7 @@ TEST_P(HotwordServiceTest, PreviousLanguageSetOnInstall) {
- }
-
- TEST_P(HotwordServiceTest, UninstallReinstallTriggeredCorrectly) {
-+#if defined(ENABLE_HOTWORDING)
- InitializeEmptyExtensionService();
- service_->Init();
-
-@@ -372,6 +375,7 @@ TEST_P(HotwordServiceTest, UninstallReinstallTriggeredCorrectly) {
- EXPECT_TRUE(HotwordServiceFactory::IsHotwordAllowed(profile()));
- EXPECT_FALSE(hotword_service->MaybeReinstallHotwordExtension());
- EXPECT_EQ(1, hotword_service->uninstall_count()); // no change
-+#endif // defined(ENABLE_HOTWORDING)
- }
-
- TEST_P(HotwordServiceTest, DisableAlwaysOnOnLanguageChange) {
-diff --git a/chrome/chrome_browser.gypi b/chrome/chrome_browser.gypi
-index 6d323eb..1aaedba 100644
---- a/chrome/chrome_browser.gypi
-+++ b/chrome/chrome_browser.gypi
-@@ -3529,6 +3529,9 @@
- ['enable_session_service==1', {
- 'sources': [ '<@(chrome_browser_session_service_sources)' ],
- }],
-+ ['enable_hotwording==1', {
-+ 'defines': [ 'ENABLE_HOTWORDING' ],
-+ }],
- ['OS!="android" and OS!="ios" and chromeos==0', {
- 'sources': [ '<@(chrome_browser_desktop_sources)' ],
- }],
---
-2.4.4
-
diff --git a/main/chromium/chromium-system-libvpx-r0.patch b/main/chromium/chromium-system-libvpx-r0.patch
deleted file mode 100644
index 2f4475d008..0000000000
--- a/main/chromium/chromium-system-libvpx-r0.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./build/linux/unbundle/libvpx.gyp.orig 2015-04-08 09:25:29.605925761 +0000
-+++ ./build/linux/unbundle/libvpx.gyp 2015-04-08 09:27:19.932142216 +0000
-@@ -24,6 +24,7 @@
- 'vpx/vpx_integer.h',
- 'vpx/vp8dx.h',
- 'vpx/vpx_encoder.h',
-+ 'vpx/vpx_frame_buffer.h',
- ],
- },
- 'includes': [
diff --git a/main/chromium/issue1107683002_20001_30001.patch b/main/chromium/issue1107683002_20001_30001.patch
deleted file mode 100644
index 1a237b6387..0000000000
--- a/main/chromium/issue1107683002_20001_30001.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: gpu/command_buffer/service/gles2_cmd_decoder.cc
-diff --git a/gpu/command_buffer/service/gles2_cmd_decoder.cc b/gpu/command_buffer/service/gles2_cmd_decoder.cc
-index 04a9eb25443cb2a25d52400ba714c850ea63eca6..9c43f88e81fe60ef82b0bf17e41c2781350164c3 100644
---- a/gpu/command_buffer/service/gles2_cmd_decoder.cc
-+++ b/gpu/command_buffer/service/gles2_cmd_decoder.cc
-@@ -2737,7 +2737,7 @@ bool GLES2DecoderImpl::Initialize(
- // make it appear RGB. If on the other hand we ask for RGBA nd get RGB we
- // can't do anything about that.
-
-- if (!surfaceless_) {
-+ if (!surfaceless_ && !surface_->IsOffscreen()) {
- GLint alpha_bits = 0;
- GLint depth_bits = 0;
- GLint stencil_bits = 0;
diff --git a/main/chromium/musl-fixes.patch b/main/chromium/musl-fixes.patch
index 049a06b8c8..144a008557 100644
--- a/main/chromium/musl-fixes.patch
+++ b/main/chromium/musl-fixes.patch
@@ -197,3 +197,23 @@
UMA_HISTOGRAM_ENUMERATION("Linux.WindowManager",
GetLinuxWindowManager(),
UMA_LINUX_WINDOW_MANAGER_COUNT);
+--- ./third_party/ffmpeg/libavutil/autorename_libavutil_cpu.c.orig
++++ ./third_party/ffmpeg/libavutil/autorename_libavutil_cpu.c
+@@ -38,7 +38,6 @@
+ #include <sys/param.h>
+ #endif
+ #include <sys/types.h>
+-#include <sys/sysctl.h>
+ #endif
+ #if HAVE_UNISTD_H
+ #include <unistd.h>
+--- ./device/serial/serial_io_handler_posix.cc.orig
++++ ./device/serial/serial_io_handler_posix.cc
+@@ -6,6 +6,7 @@
+
+ #include <sys/ioctl.h>
+ #include <termios.h>
++#include <asm-generic/ioctls.h>
+
+ #include "base/posix/eintr_wrapper.h"
+
diff --git a/main/chromium/no-mallinfo.patch b/main/chromium/no-mallinfo.patch
index 865db77dcb..c84d762402 100644
--- a/main/chromium/no-mallinfo.patch
+++ b/main/chromium/no-mallinfo.patch
@@ -9,3 +9,34 @@
size_t GetMemoryUsageKB() {
struct mallinfo minfo = mallinfo();
uint64_t mem_usage =
+--- ./base/trace_event/malloc_dump_provider.cc.orig
++++ ./base/trace_event/malloc_dump_provider.cc
+@@ -26,9 +26,10 @@
+ // Called at trace dump point time. Creates a snapshot the memory counters for
+ // the current process.
+ bool MallocDumpProvider::OnMemoryDump(ProcessMemoryDump* pmd) {
++#if defined(__GLIBC__)
+ struct mallinfo info = mallinfo();
+ DCHECK_GE(info.arena + info.hblkhd, info.uordblks);
+-
++#endif
+ MemoryAllocatorDump* dump = pmd->CreateAllocatorDump("malloc");
+ if (!dump)
+ return false;
+--- ./base/trace_event/malloc_dump_provider.cc.orig
++++ ./base/trace_event/malloc_dump_provider.cc
+@@ -39,12 +39,14 @@
+ // |arena| is 0 and the outer pages size is reported by |hblkhd|. In case of
+ // dlmalloc the total is given by |arena| + |hblkhd|.
+ // For more details see link: http://goo.gl/fMR8lF.
++#if defined(__GLIBC__)
+ dump->AddScalar(MemoryAllocatorDump::kNameOuterSize,
+ MemoryAllocatorDump::kUnitsBytes, info.arena + info.hblkhd);
+
+ // Total allocated space is given by |uordblks|.
+ dump->AddScalar(MemoryAllocatorDump::kNameInnerSize,
+ MemoryAllocatorDump::kUnitsBytes, info.uordblks);
++#endif
+
+ return true;
+ }