aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/dahdi-linux-grsec/APKBUILD2
-rw-r--r--main/gcc/APKBUILD6
-rw-r--r--main/gnutls/APKBUILD4
-rw-r--r--main/gross/APKBUILD4
-rw-r--r--main/gross/grossd.initd8
-rw-r--r--main/iscsitarget-grsec/APKBUILD2
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch (renamed from main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908090749.patch)27
-rw-r--r--main/postgresql/APKBUILD11
-rw-r--r--main/postgresql/postgresql.confd2
-rw-r--r--main/postgresql/postgresql.pre-upgrade30
-rw-r--r--main/uclibc/APKBUILD4
-rw-r--r--main/uclibc/uclibcconfig2
-rw-r--r--main/xtables-addons/APKBUILD2
14 files changed, 76 insertions, 34 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index 919927a050..cb2e3a73bd 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -14,7 +14,7 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=2.2.0
-pkgrel=5
+pkgrel=6
pkgdesc="Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
license="GPL"
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index fff88ea06b..8c432b0ad8 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -3,11 +3,11 @@ pkgname=gcc
pkgver=4.4.1
_specsver=0.1.4
_espfver=0.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
-depends="binutils"
+depends="binutils libgcc"
makedepends="bison flex gmp-dev mpfr-dev texinfo"
subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp"
source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
@@ -89,7 +89,7 @@ libcxx() {
gpp() {
pkgdesc="GNU C++ standard library and compiler"
- depends=
+ depends="libstdc++"
local libexec=usr/libexec/gcc/${CHOST:-i486-alpine-linux-uclibc}/$pkgver
mkdir -p "$subpkgdir/$libexec" \
"$subpkgdir"/usr/bin \
diff --git a/main/gnutls/APKBUILD b/main/gnutls/APKBUILD
index f8dd61f2d5..c2af68220a 100644
--- a/main/gnutls/APKBUILD
+++ b/main/gnutls/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnutls
pkgver=2.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="A library which provides a secure connection"
url="http://www.gnu.org/software/gnutls/"
license="GPL"
@@ -12,6 +12,8 @@ install=
subpackages="$pkgname-doc $pkgname-dev"
source="http://ftp.gnu.org/pub/gnu/gnutls/$pkgname-$pkgver.tar.bz2"
+depends_dev="libgcrypt-dev libgpg-error-dev"
+
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/main/gross/APKBUILD b/main/gross/APKBUILD
index dd1104536c..48c4579225 100644
--- a/main/gross/APKBUILD
+++ b/main/gross/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gross
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Greylisting of suspicious sources"
url="http://code.google.com/p/gross/"
license="BSD"
@@ -46,7 +46,7 @@ build() {
}
md5sums="f8f81b36850dcda30cb81799b9cee3b6 gross-1.0.1.tar.gz
-b0d8635b64c4a90d72c49e868f4c4c32 grossd.initd
+5c8c2aa3ad8108812850717c6134493c grossd.initd
5ca1c6e51c3243236e6564480b20279b grossd.confd
bb75b119ac96b8f99831ce6df810003f gross-1.0.1-configure.ac.patch
7c504b653c71dcf7b192bc487b3516fd gross-1.0.1-default-conf.patch
diff --git a/main/gross/grossd.initd b/main/gross/grossd.initd
index 3d1c43d708..4d59b623a9 100644
--- a/main/gross/grossd.initd
+++ b/main/gross/grossd.initd
@@ -4,6 +4,7 @@ NAME="grossd"
DAEMON="/usr/sbin/$NAME"
DAEMON_USER="gross"
DAEMON_GROUP="gross"
+pidfile=/var/run/gross/$NAME.pid
depend() {
need net
@@ -20,16 +21,15 @@ check_config() {
start() {
check_config || return 1
ebegin "Starting ${NAME}"
- start-stop-daemon --start --quiet \
+ start-stop-daemon --start --quiet --pidfile ${pidfile} \
--exec ${DAEMON} -- \
- -p /var/run/gross/grossd.pid \
- -u ${DAEMON_USER} ${OPTS}
+ -p ${pidfile} -u ${DAEMON_USER} ${OPTS}
eend $?
}
stop() {
ebegin "Stopping ${NAME}"
- start-stop-daemon --stop --pidfile /var/run/gross/grossd.pid
+ start-stop-daemon --stop --exec ${DAEMON}
eend $?
}
diff --git a/main/iscsitarget-grsec/APKBUILD b/main/iscsitarget-grsec/APKBUILD
index affef0910b..8a1dec1c46 100644
--- a/main/iscsitarget-grsec/APKBUILD
+++ b/main/iscsitarget-grsec/APKBUILD
@@ -15,7 +15,7 @@ if [ -f ../iscsitarget/APKBUILD ]; then
fi
pkgname=${_realname}-${_flavor}
pkgver=${pkgver:-0.4.17}
-pkgrel=5
+pkgrel=6
pkgdesc="$_flavor kernel modules for iscsitarget"
url="http://iscsitarget.sourceforge.net/"
license="GPL-2"
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 625989df1b..6d88c138a4 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.30.4
_kernver=2.6.30
-pkgrel=3
+pkgrel=4
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs"
@@ -13,7 +13,7 @@ _config=${config:-kernelconfig}
install="$pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- grsecurity-2.1.14-2.6.30.4-200908090749.patch
+ grsecurity-2.1.14-2.6.30.4-200908122115.patch
linux-nbma-mroute-v4-2.6.30.diff
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
@@ -113,7 +113,7 @@ dev() {
md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
d0fc44b54ba5953140b3f2aa9a1f2580 patch-2.6.30.4.bz2
-78f3778d96c03006ba0b4c96ed885cd6 grsecurity-2.1.14-2.6.30.4-200908090749.patch
+8b90a9def6800972fd09685bb73c5945 grsecurity-2.1.14-2.6.30.4-200908122115.patch
7420c0b1095335990313656b114e1379 linux-nbma-mroute-v4-2.6.30.diff
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
60adb085be0ab268c0f27279ae2b2bab kernelconfig
diff --git a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908090749.patch b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch
index 3fff0bbb81..6f697a13fa 100644
--- a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908090749.patch
+++ b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch
@@ -8320,7 +8320,7 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/efi_stub_32.S linux-2.6.30.4/arch/x86/
efi_rt_function_ptr:
diff -urNp linux-2.6.30.4/arch/x86/kernel/entry_32.S linux-2.6.30.4/arch/x86/kernel/entry_32.S
--- linux-2.6.30.4/arch/x86/kernel/entry_32.S 2009-07-24 17:47:51.000000000 -0400
-+++ linux-2.6.30.4/arch/x86/kernel/entry_32.S 2009-07-30 09:48:09.945662533 -0400
++++ linux-2.6.30.4/arch/x86/kernel/entry_32.S 2009-08-12 21:15:21.098460043 -0400
@@ -192,7 +192,7 @@
#endif /* CONFIG_X86_32_LAZY_GS */
@@ -8525,11 +8525,11 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/entry_32.S linux-2.6.30.4/arch/x86/ker
/* since we are on a wrong stack, we cant make it a C code :( */
- PER_CPU(gdt_page, %ebx)
+#ifdef CONFIG_SMP
-+ movl PER_CPU_VAR(cpu_number), %ebx;
-+ shll $PAGE_SHIFT_asm, %ebx;
-+ addl $cpu_gdt_table, %ebx;
++ movl PER_CPU_VAR(cpu_number), %ebx
++ shll $PAGE_SHIFT_asm, %ebx
++ addl $cpu_gdt_table, %ebx
+#else
-+ movl $cpu_gdt_table, %ebx;
++ movl $cpu_gdt_table, %ebx
+#endif
GET_DESC_BASE(GDT_ENTRY_ESPFIX_SS, %ebx, %eax, %ax, %al, %ah)
addl %esp, %eax
@@ -8595,14 +8595,18 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/entry_32.S linux-2.6.30.4/arch/x86/ker
CFI_ADJUST_CFA_OFFSET -24
diff -urNp linux-2.6.30.4/arch/x86/kernel/entry_64.S linux-2.6.30.4/arch/x86/kernel/entry_64.S
--- linux-2.6.30.4/arch/x86/kernel/entry_64.S 2009-07-24 17:47:51.000000000 -0400
-+++ linux-2.6.30.4/arch/x86/kernel/entry_64.S 2009-07-30 09:48:09.945662533 -0400
-@@ -1073,7 +1073,8 @@ ENTRY(\sym)
++++ linux-2.6.30.4/arch/x86/kernel/entry_64.S 2009-08-12 21:15:21.099483377 -0400
+@@ -1073,7 +1073,12 @@ ENTRY(\sym)
TRACE_IRQS_OFF
movq %rsp,%rdi /* pt_regs pointer */
xorl %esi,%esi /* no error code */
- PER_CPU(init_tss, %rbp)
++#ifdef CONFIG_SMP
+ imul $TSS_size, PER_CPU_VAR(cpu_number), %ebp
+ lea init_tss(%rbp), %rbp
++#else
++ lea init_tss(%rip), %rbp
++#endif
subq $EXCEPTION_STKSZ, TSS_ist + (\ist - 1) * 8(%rbp)
call \do_sym
addq $EXCEPTION_STKSZ, TSS_ist + (\ist - 1) * 8(%rbp)
@@ -11088,7 +11092,7 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/vm86_32.c linux-2.6.30.4/arch/x86/kern
tsk->thread.sysenter_cs = 0;
diff -urNp linux-2.6.30.4/arch/x86/kernel/vmi_32.c linux-2.6.30.4/arch/x86/kernel/vmi_32.c
--- linux-2.6.30.4/arch/x86/kernel/vmi_32.c 2009-07-24 17:47:51.000000000 -0400
-+++ linux-2.6.30.4/arch/x86/kernel/vmi_32.c 2009-07-30 09:48:09.962543704 -0400
++++ linux-2.6.30.4/arch/x86/kernel/vmi_32.c 2009-08-12 21:15:21.104308164 -0400
@@ -102,18 +102,43 @@ static unsigned patch_internal(int call,
{
u64 reloc;
@@ -11149,7 +11153,7 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/vmi_32.c linux-2.6.30.4/arch/x86/kerne
vmi_ops.set_pte(pte, (pte_t *)pmd, VMI_PAGE_PD);
}
#endif
-@@ -438,8 +463,8 @@ vmi_startup_ipi_hook(int phys_apicid, un
+@@ -438,10 +463,10 @@ vmi_startup_ipi_hook(int phys_apicid, un
ap.ss = __KERNEL_DS;
ap.esp = (unsigned long) start_esp;
@@ -11158,7 +11162,10 @@ diff -urNp linux-2.6.30.4/arch/x86/kernel/vmi_32.c linux-2.6.30.4/arch/x86/kerne
+ ap.ds = __KERNEL_DS;
+ ap.es = __KERNEL_DS;
ap.fs = __KERNEL_PERCPU;
- ap.gs = 0;
+- ap.gs = 0;
++ ap.gs = __KERNEL_STACK_CANARY;
+
+ ap.eflags = 0;
@@ -634,12 +659,20 @@ static inline int __init activate_vmi(vo
u64 reloc;
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index a2d921ed14..205c3f89c5 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -1,16 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postgresql
-pkgver=8.3.7
-pkgrel=3
+pkgver=8.4.0
+pkgrel=0
pkgdesc="A sophisticated object-relational DBMS"
url="http://www.postgresql.org/"
license="BSD"
depends="bbsuid"
+install="$pkgname.pre-upgrade"
makedepends="readline-dev openssl-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc libpq $pkgname-client"
source="ftp://ftp.$pkgname.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
$pkgname.initd
$pkgname.confd
+ $install
"
build() {
@@ -45,6 +47,7 @@ client() {
}
-md5sums="7b7e91a2221e55fe1b167e663217a96d postgresql-8.3.7.tar.bz2
+md5sums="1f172d5f60326e972837f58fa5acd130 postgresql-8.4.0.tar.bz2
6dd7bd7c97252312357a255237115b38 postgresql.initd
-ea3320c56a22f5c305199886c2766387 postgresql.confd"
+6218755fde294b7d17b77d280a9c9106 postgresql.confd
+a5c671b718f7adc9735b1ed89a5c26e1 postgresql.pre-upgrade"
diff --git a/main/postgresql/postgresql.confd b/main/postgresql/postgresql.confd
index 56561b0c40..22ff61cd37 100644
--- a/main/postgresql/postgresql.confd
+++ b/main/postgresql/postgresql.confd
@@ -1,5 +1,5 @@
# PostgreSQL's Database Directory
-PGDATA="/var/lib/postgresql/8.3/data"
+PGDATA="/var/lib/postgresql/8.4/data"
# PostgreSQL User
PGUSER="postgres"
diff --git a/main/postgresql/postgresql.pre-upgrade b/main/postgresql/postgresql.pre-upgrade
new file mode 100644
index 0000000000..358e9986b4
--- /dev/null
+++ b/main/postgresql/postgresql.pre-upgrade
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+
+current="$1"
+compare=$(apk version -t $current 8.4)
+
+# check if we upgrade from earlier than 8.4 and if it is running
+if [ "$compare" != "<" ] || ! /etc/init.d/postgresql --quiet status; then
+ exit 0
+fi
+
+if [ -f /etc/conf.d/postgresql ]; then
+ . /etc/conf.d/postgresql
+fi
+
+cat <<EOF
+* You are upgrading to postgres 8.4 wich is not compatible with the running
+* See: http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html
+*
+* The corresponding steps for Alpine Linux is:
+*
+* pg_dumpall -U ${PGUSER:-postgres} > dumpfile
+* /etc/init.d/postgresql stop
+* apk add -u postgresql
+* /etc/init.d/postgresql setup
+* /etc/init.d/postgresl start
+* psql -U ${PGUSER:-postgres} -f dumpfile
+*
+EOF
+exit 1
diff --git a/main/uclibc/APKBUILD b/main/uclibc/APKBUILD
index 4bb72e6da1..fd6555f124 100644
--- a/main/uclibc/APKBUILD
+++ b/main/uclibc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc
pkgver=0.9.30.1
-pkgrel=14
+pkgrel=15
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -72,7 +72,7 @@ bbb8475963e791f596c34c81ef5583d7 uclibc-resolv-cname-fix.diff
220260c979eca4558827d0e7ec8aa8b6 uclibc-fork-hidden.diff
55bb709f5efd937df323f0d39a202cfd uclibc-fork-hook.diff
a7310494a8073ebd43e1d437657532ef uclibc-getaddrinfo-netlink.diff
-0a87f57d3e5001027f43b7c959d96319 uclibcconfig
+36b28777f4c49af39268920fbade41b1 uclibcconfig
329b92fec717c8808c3fa9ffd68f2dfb 0001-first-pass-at-implementing-at-funcs.patch
7ffa41082d9de2bc512b4bed9577bdf9 0002-add-hidden-aliases-for-openat-funcs.patch
e12c647716eef19dd4ad08602dcc435b 0003-remove-libc_hidden_def-mknodat.patch"
diff --git a/main/uclibc/uclibcconfig b/main/uclibc/uclibcconfig
index 8cc64d90a8..78835525f8 100644
--- a/main/uclibc/uclibcconfig
+++ b/main/uclibc/uclibcconfig
@@ -200,7 +200,7 @@ UCLIBC_HAS_GNU_GETSUBOPT=y
UCLIBC_HAS_REGEX=y
UCLIBC_HAS_REGEX_OLD=y
UCLIBC_HAS_FNMATCH=y
-UCLIBC_HAS_FNMATCH_OLD=y
+# UCLIBC_HAS_FNMATCH_OLD is not set
UCLIBC_HAS_WORDEXP=y
UCLIBC_HAS_FTW=y
UCLIBC_HAS_GLOB=y
diff --git a/main/xtables-addons/APKBUILD b/main/xtables-addons/APKBUILD
index febbcdd72e..1196e3efcb 100644
--- a/main/xtables-addons/APKBUILD
+++ b/main/xtables-addons/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xtables-addons
pkgver=1.17
-pkgrel=0
+pkgrel=1
pkgdesc="Netfilter userspace extensions for iptables"
url="http://xtables-addons.sourceforge.net/"
license="GPL"