aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/dnsmasq/APKBUILD2
-rw-r--r--main/dnsmasq/dnsmasq.initd8
2 files changed, 6 insertions, 4 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index 022c712349..136453c62d 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -15,7 +15,7 @@
#
pkgname=dnsmasq
pkgver=2.80
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight DNS, DHCP, RA, TFTP and PXE server"
url="http://www.thekelleys.org.uk/dnsmasq/"
arch="all"
diff --git a/main/dnsmasq/dnsmasq.initd b/main/dnsmasq/dnsmasq.initd
index 2932b03e3a..141ed5b682 100644
--- a/main/dnsmasq/dnsmasq.initd
+++ b/main/dnsmasq/dnsmasq.initd
@@ -52,9 +52,11 @@ setup_bridge() {
if ! [ -d /sys/class/net/$BRIDGE ]; then
ip link add dev $BRIDGE type bridge
fi
- ip addr add ${BRIDGE_ADDR}/${BRIDGE_NETMASK} dev $BRIDGE \
- && ip link set dev $BRIDGE address ${BRIDGE_MAC} \
- && ip link set dev $BRIDGE up
+
+ ip link set dev $BRIDGE address ${BRIDGE_MAC} && \
+ for ADDR in $BRIDGE_ADDR $BRIDGE_ADDR_EXTRA; do
+ ip addr add ${ADDR}/${BRIDGE_NETMASK} dev $BRIDGE
+ done && ip link set dev $BRIDGE up
echo 1 > /proc/sys/net/ipv4/ip_forward
echo 0 > /proc/sys/net/ipv6/conf/${BRIDGE}/accept_dad || true