aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/librelp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/librelp/APKBUILD b/main/librelp/APKBUILD
new file mode 100644
index 0000000000..de86652fa8
--- /dev/null
+++ b/main/librelp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=librelp
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="The Reliable Event Logging Protocol library"
+url="https://www.rsyslog.com"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gnutls-dev"
+subpackages="$pkgname-dev"
+source="http://download.rsyslog.com/librelp/$pkgname-$pkgver.tar.gz"
+options="!check" # XXX: all tests fail, don't know why
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6e60398c68a78f4b4202a697e144f1516ff3bbb32192f745b52c77d107954febf8cb31d2e166efa96c00122f6807860ecd01084f1d3d4005336f2cb75e6461c9 librelp-1.3.0.tar.gz"