aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/mesa/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 4041278b3a..3d72035334 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=17.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -18,11 +18,12 @@ subpackages="$pkgname-dev
$pkgname-libwayland-egl:_wayland
"
+_llvmver=4
depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
libxdamage-dev libxfixes-dev libxcb-dev glproto dri3proto presentproto
libxshmfence-dev"
makedepends="$depends_dev expat-dev xextproto python2 libxt-dev makedepend
- talloc-dev py-libxml2 flex bison llvm-dev eudev-dev libvdpau-dev
+ talloc-dev py-libxml2 flex bison llvm$_llvmver-dev eudev-dev libvdpau-dev
libxvmc-dev gettext zlib-dev wayland-dev libelf-dev py-mako
autoconf automake libtool"
source="https://mesa.freedesktop.org/archive/mesa-$pkgver.tar.xz
@@ -83,6 +84,7 @@ build() {
--with-gallium-drivers=${_gallium_drivers} \
--with-dri-drivers=${_dri_drivers} \
--with-vulcan-drivers=${_vulkan_drivers} \
+ --with-llvm-prefix=/usr/lib/llvm$_llvmver \
--enable-llvm-shared-libs \
--enable-gallium-llvm \
--with-egl-platforms=x11,drm,wayland \