aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/libuv/APKBUILD9
-rw-r--r--main/libuv/disable-setuid-test.patch14
-rw-r--r--main/libuv/test-connection-unspecified.patch24
3 files changed, 35 insertions, 12 deletions
diff --git a/main/libuv/APKBUILD b/main/libuv/APKBUILD
index ada6c5b5a8..af79fa580d 100644
--- a/main/libuv/APKBUILD
+++ b/main/libuv/APKBUILD
@@ -2,7 +2,7 @@
# Conttributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libuv
-pkgver=1.19.1
+pkgver=1.19.2
pkgrel=0
pkgdesc="Cross-platform asychronous I/O"
url="http://libuv.org"
@@ -12,12 +12,12 @@ makedepends="automake autoconf libtool linux-headers"
subpackages="$pkgname-dev $pkgname-dbg"
source="https://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz
disable-setuid-test.patch
+ test-connection-unspecified.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
default_prepare
-
cd "$builddir"
sh autogen.sh
}
@@ -46,5 +46,6 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="516b17afe5ea12f5c53abe68ea5fac9853f20c89fff754c054c041bb9d88a55e5a691842e509348617444f6080311c963707dd272c91c7ff7baf2c4d516b2d7f libuv-v1.19.1.tar.gz
-478d25c8905cd393b9ced0f1b16e70794a7ef20fb9eb212fd74e50beca3f5a33a6a5267616abecf470426ed3d00efec51df468745ff43c0de05c0ad8234f1eb3 disable-setuid-test.patch"
+sha512sums="8f317bb9c173af32d19e8f9f5c64e2cb50178166a109e84218ea630667a5cbd8c6c700c53baf89d2754e615b8526c22d5514bf3c2fe123913b297fbe5727be5e libuv-v1.19.2.tar.gz
+7471ec9bd513c50cd38f9c38ece5fe45c3dc02c9e941a6db4b480efc6d0dfc86a7a32608735ca49439d23653369fa8444eb70e41b99d6dcbf32db0375ec92793 disable-setuid-test.patch
+e3faf7b148ce2fb4d28de27c8b096282a7d93bdd4ca253c89b33f17bcc2a123698b8ed9aada6aa6ba502d3a261a1ac36fa2faa245df4969c85a60ee5da0f96fa test-connection-unspecified.patch"
diff --git a/main/libuv/disable-setuid-test.patch b/main/libuv/disable-setuid-test.patch
index 3c6e016113..4d9cb38dc0 100644
--- a/main/libuv/disable-setuid-test.patch
+++ b/main/libuv/disable-setuid-test.patch
@@ -1,8 +1,6 @@
-diff --git a/test/test-list.h b/test/test-list.h
-index 3a1e82a..dd25e69 100644
--- a/test/test-list.h
+++ b/test/test-list.h
-@@ -240,8 +240,10 @@ TEST_DECLARE (spawn_detached)
+@@ -253,8 +253,10 @@
TEST_DECLARE (spawn_and_kill_with_std)
TEST_DECLARE (spawn_and_ping)
TEST_DECLARE (spawn_preserve_env)
@@ -13,7 +11,7 @@ index 3a1e82a..dd25e69 100644
TEST_DECLARE (spawn_stdout_to_file)
TEST_DECLARE (spawn_stdout_and_stderr_to_file)
TEST_DECLARE (spawn_stdout_and_stderr_to_file2)
-@@ -351,7 +353,9 @@ TEST_DECLARE (win32_signum_number)
+@@ -384,7 +386,9 @@
TEST_DECLARE (emfile)
TEST_DECLARE (close_fd)
TEST_DECLARE (spawn_fs_open)
@@ -22,8 +20,8 @@ index 3a1e82a..dd25e69 100644
+#endif
TEST_DECLARE (we_get_signal)
TEST_DECLARE (we_get_signals)
- TEST_DECLARE (signal_multiple_loops)
-@@ -669,8 +673,10 @@ TASK_LIST_START
+ TEST_DECLARE (we_get_signal_one_shot)
+@@ -747,8 +751,10 @@
TEST_ENTRY (spawn_and_kill_with_std)
TEST_ENTRY (spawn_and_ping)
TEST_ENTRY (spawn_preserve_env)
@@ -34,7 +32,7 @@ index 3a1e82a..dd25e69 100644
TEST_ENTRY (spawn_stdout_to_file)
TEST_ENTRY (spawn_stdout_and_stderr_to_file)
TEST_ENTRY (spawn_stdout_and_stderr_to_file2)
-@@ -701,7 +707,9 @@ TASK_LIST_START
+@@ -782,7 +788,9 @@
TEST_ENTRY (emfile)
TEST_ENTRY (close_fd)
TEST_ENTRY (spawn_fs_open)
@@ -43,4 +41,4 @@ index 3a1e82a..dd25e69 100644
+#endif
TEST_ENTRY (we_get_signal)
TEST_ENTRY (we_get_signals)
- TEST_ENTRY (signal_multiple_loops)
+ TEST_ENTRY (we_get_signal_one_shot)
diff --git a/main/libuv/test-connection-unspecified.patch b/main/libuv/test-connection-unspecified.patch
new file mode 100644
index 0000000000..225cfc066c
--- /dev/null
+++ b/main/libuv/test-connection-unspecified.patch
@@ -0,0 +1,24 @@
+# https://github.com/libuv/libuv/issues/1766
+--- a/test/test-connect-unspecified.c
++++ b/test/test-connect-unspecified.c
+@@ -48,12 +48,14 @@
+ (const struct sockaddr*) &addr4,
+ connect_4) == 0);
+
+- ASSERT(uv_tcp_init(loop, &socket6) == 0);
+- ASSERT(uv_ip6_addr("::", TEST_PORT, &addr6) == 0);
+- ASSERT(uv_tcp_connect(&connect6,
+- &socket6,
+- (const struct sockaddr*) &addr6,
+- connect_6) == 0);
++ if (can_ipv6()) {
++ ASSERT(uv_tcp_init(loop, &socket6) == 0);
++ ASSERT(uv_ip6_addr("::", TEST_PORT, &addr6) == 0);
++ ASSERT(uv_tcp_connect(&connect6,
++ &socket6,
++ (const struct sockaddr*) &addr6,
++ connect_6) == 0);
++ }
+
+ ASSERT(uv_run(loop, UV_RUN_DEFAULT) == 0);
+