aboutsummaryrefslogtreecommitdiffstats
path: root/non-free
diff options
context:
space:
mode:
Diffstat (limited to 'non-free')
-rw-r--r--non-free/yed/APKBUILD33
-rw-r--r--non-free/yed/yed3
-rw-r--r--non-free/yed/yed.desktop8
-rw-r--r--non-free/yed/yed.install12
4 files changed, 56 insertions, 0 deletions
diff --git a/non-free/yed/APKBUILD b/non-free/yed/APKBUILD
new file mode 100644
index 0000000000..48442bea2a
--- /dev/null
+++ b/non-free/yed/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Will Sinatra <wpsinatra@gmail.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+pkgname=yed
+pkgver=3.19
+pkgrel=0
+pkgdesc="Very powerful graph editor written in java"
+url="http://www.yworks.com/en/products_yed_about.html"
+arch="noarch"
+license="custom"
+depends="openjdk8-jre"
+options="!check" #No checks
+source="yed-$pkgver.zip::https://www.yworks.com/resources/yed/demo/yEd-$pkgver.zip
+ yed.desktop
+ yed
+ "
+
+package() {
+ install -Dm644 $srcdir/yed-$pkgver/yed.jar $pkgdir/usr/share/java/yed/yed.jar
+ install -dm755 $pkgdir/usr/share/java/yed/lib
+ install -m644 $srcdir/yed-$pkgver/lib/* $pkgdir/usr/share/java/yed/lib/
+
+ install -Dm644 $srcdir/yed-$pkgver/license.html $pkgdir/usr/share/licenses/yed/license.html
+
+ install -Dm644 $srcdir/yed-$pkgver/icons/yicon32.png $pkgdir/usr/share/pixmaps/yed.png
+
+ install -Dm644 $srcdir/yed.desktop $pkgdir/usr/share/applications/yed.desktop
+
+ install -Dm755 $srcdir/yed $pkgdir/usr/bin/yed
+}
+
+sha512sums="72deab9ae1c509d7d479d442ef4fdc502b8bd4c305f772e632939f1eaf6156cf5d3a6ee7f902b352bbe17fa75bacabb11546f6870fbe9be610c0311a4a6a58af yed-3.19.zip
+249ab5342d1996f9641714b887e5f8425fd77fdceb5b1df1b13573a2f25317cbc99352cd21aa9aafb9c1101411d06b45c2669cea480f8f5282301722414b419d yed.desktop
+a5c524172e592088b4e82d2fa5d2ba5a62e4953a479fa1387dc7a0f1906ee495723de7fd0ae5c6548d8b43ef51aa0326c861d131d58acb458fd071493653eb22 yed"
diff --git a/non-free/yed/yed b/non-free/yed/yed
new file mode 100644
index 0000000000..aa3021c750
--- /dev/null
+++ b/non-free/yed/yed
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/bin/java -jar /usr/share/java/yed/yed.jar "$@"
diff --git a/non-free/yed/yed.desktop b/non-free/yed/yed.desktop
new file mode 100644
index 0000000000..607cc78451
--- /dev/null
+++ b/non-free/yed/yed.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Icon=yed
+Exec=yed %f
+StartUpNotify=true
+StartUpWMClass=com-yworks-A-yEd
+Name=yEd Graph Editor
+Categories=Application;Graphics;VectorGraphics;Java;
diff --git a/non-free/yed/yed.install b/non-free/yed/yed.install
new file mode 100644
index 0000000000..030cc4e50a
--- /dev/null
+++ b/non-free/yed/yed.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ post_install $1
+}
+
+post_install() {
+ echo ">>> You have to read and accept the license agreement under"
+ echo ">>> /usr/share/licenses/yed/license.html before using yEd."
+}
+
+op=$1
+shift
+$op $*