aboutsummaryrefslogtreecommitdiffstats
path: root/test/repo2/test-a/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'test/repo2/test-a/APKBUILD')
-rw-r--r--test/repo2/test-a/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/test/repo2/test-a/APKBUILD b/test/repo2/test-a/APKBUILD
index a014906b0a..cafc43f580 100644
--- a/test/repo2/test-a/APKBUILD
+++ b/test/repo2/test-a/APKBUILD
@@ -12,23 +12,23 @@ makedepends=
install=
subpackages=
source=""
+builddir="$srcdir/$pkgname-$pkgver"
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- mkdir -p "$_builddir"
+ mkdir -p "$builddir"
}
build() {
- cd "$_builddir"
- cat > $pkgname << __EOF__
-#!/bin/sh
-echo "hello from $pkgname-$pkgver"
-__EOF__
+ cd "$builddir"
+ cat > $pkgname <<-EOF
+ #!/bin/sh
+ echo "hello from $pkgname-$pkgver"
+ EOF
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}
-md5sums="" #generate with 'abuild checksum'
+sha512sums="" #generate with 'abuild checksum'