aboutsummaryrefslogtreecommitdiffstats
path: root/testing/alpine-ipxe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/alpine-ipxe/APKBUILD')
-rw-r--r--testing/alpine-ipxe/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/testing/alpine-ipxe/APKBUILD b/testing/alpine-ipxe/APKBUILD
new file mode 100644
index 0000000000..fb7cb57e22
--- /dev/null
+++ b/testing/alpine-ipxe/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=alpine-ipxe
+pkgver=1.0_git20180220
+_sha=47849be3a900c546cf92066849be0806f4e611d9
+pkgrel=0
+pkgdesc="iPXE build for Alpine Linux netboot"
+url="https://boot.alpinelinux.org"
+arch="x86 x86_64"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="xz-dev perl coreutils bash syslinux xorriso"
+options="!strip !check" # has not tests
+install=""
+subpackages=""
+source="ipxe-$pkgver.tar.gz::https://github.com/ipxe/ipxe/archive/$_sha.tar.gz
+ DST_Root_CA_X3.pem
+ alpine.ipxe
+ "
+builddir="$srcdir/ipxe-$_sha/src"
+
+prepare() {
+ cd "$builddir"
+ mkdir -p config/local
+ echo '#define NET_PROTO_IPV6' >> config/local/general.h
+ echo '#define DOWNLOAD_PROTO_HTTPS' >> config/local/general.h
+ echo '#define IMAGE_TRUST_CMD' >> config/local/general.h
+ echo '#define PING_CMD' >> config/local/general.h
+}
+
+build() {
+ cd "$builddir"
+ make \
+ EMBED="$srcdir/alpine.ipxe" \
+ CERT="$srcdir/DST_Root_CA_X3.pem" \
+ TRUST="$srcdir/DST_Root_CA_X3.pem" \
+ bin/ipxe.iso \
+ bin/ipxe.lkrn \
+ bin/ipxe.pxe \
+ bin-x86_64-efi/ipxe.efi
+}
+
+package() {
+ cd "$builddir"
+ install -Dm644 bin/ipxe.lkrn \
+ "$pkgdir"/usr/share/$pkgname/ipxe.lkrn
+ install -Dm644 bin/ipxe.pxe \
+ "$pkgdir"/usr/share/$pkgname/ipxe.pxe
+ install -Dm644 bin-x86_64-efi/ipxe.efi \
+ "$pkgdir"/usr/share/$pkgname/ipxe.efi
+ install -Dm644 bin/ipxe.iso \
+ "$pkgdir"/usr/share/$pkgname/ipxe.iso
+}
+
+sha512sums="abc070ed07970e5307f04f5da3da4916c98016bf0a4115ab04979ecc5e7c452ca5102799ddab926e0ae9867c37c311de785dc93a736bf8f0809d5ea8e3cd3732 ipxe-1.0_git20180220.tar.gz
+1f52b62aa9e3ec0656ea3cb5c8e52eda924d58728e64bb03ca6c112858b91b13cf0a9328b105bb232973e240406b240ed14e72b5bd325e82e6fddf3126dbcc58 DST_Root_CA_X3.pem
+5569ba14ed3a164e72edd43e6b9df63fcbc59025c6729f55cbbedf2d513a83075471276a760174432eb2c6da86127a4b68fe1a2cae54408ff53b958261d06f0b alpine.ipxe"