aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ameba/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ameba/fix-makefile.patch')
-rw-r--r--testing/ameba/fix-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/ameba/fix-makefile.patch b/testing/ameba/fix-makefile.patch
new file mode 100644
index 0000000000..a2ed851d74
--- /dev/null
+++ b/testing/ameba/fix-makefile.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,16 +2,19 @@
+ PREFIX ?= /usr/local
+ SHARD_BIN ?= ../../bin
+
+-build:
++.PHONY: build
++build: bin/ameba
++
++bin/ameba:
+ $(CRYSTAL_BIN) build --no-debug -o bin/ameba src/cli.cr $(CRFLAGS)
+ clean:
+ rm -f ./bin/ameba
+-install: build
++install: bin/ameba
+ mkdir -p $(PREFIX)/bin
+ cp ./bin/ameba $(PREFIX)/bin
+-bin: build
++bin: bin/ameba
+ mkdir -p $(SHARD_BIN)
+ cp ./bin/ameba $(SHARD_BIN)
+-test: build
+- $(CRYSTAL_BIN) spec
++test: bin/ameba
++ $(CRYSTAL_BIN) spec $(SPEC_FLAGS)
+ ./bin/ameba