aboutsummaryrefslogtreecommitdiffstats
path: root/testing/android-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testing/android-tools/Makefile')
-rw-r--r--testing/android-tools/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/android-tools/Makefile b/testing/android-tools/Makefile
index 021975d7c9..679df34896 100644
--- a/testing/android-tools/Makefile
+++ b/testing/android-tools/Makefile
@@ -1,8 +1,8 @@
-all: mkbootimg fastboot adb
+all: mkbootimg fastboot adb mksdcard
install:
install -m755 -d $(DESTDIR)/usr/bin
- install -m755 -t $(DESTDIR)/usr/bin mkbootimg fastboot adb
+ install -m755 -t $(DESTDIR)/usr/bin mkbootimg fastboot adb mksdcard
clean:
rm -f **/*.o
@@ -99,3 +99,12 @@ FASTBOOT_LIBS += -lz -ldl -lpcre
fastboot: $(FASTBOOT_SRCS)
$(CC) -o $@ $(CFLAGS) $(FASTBOOT_CFLAGS) $(LDFLAGS) $(FASTBOOT_SRCS) $(FASTBOOT_LIBS)
+
+
+MKSDCARD_SRCS += $(wildcard sdk/emulator/mksdcard/src/source/*.c)
+
+mksdcard: $(MKSDCARD_SRCS)
+ $(CC) -o $@ $(CFLAGS) $(MKSDCARD_CFLAGS) $(LDFLAGS) $(MKSDCARD_SRCS) $(MKSDCARD_LIBS)
+
+
+