aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-backtrace/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apache-mod-backtrace/Makefile.in')
-rw-r--r--testing/apache-mod-backtrace/Makefile.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/apache-mod-backtrace/Makefile.in b/testing/apache-mod-backtrace/Makefile.in
new file mode 100644
index 0000000000..1f05b116f7
--- /dev/null
+++ b/testing/apache-mod-backtrace/Makefile.in
@@ -0,0 +1,35 @@
+#
+# Makefile for mod_backtrace
+#
+# Based off of Makefile for mod_auth_ntlm_winbind by
+# Matt Smith <mcs@darkregion.net>, 2011/01/04
+#
+
+# Programs
+
+APXS = @APXS@
+APXS_FLAGS = @APXS_FLAGS@
+SODIR = @SODIR@
+APXSLIBDIR=$(DESTDIR)/$(shell $(APXS) -q LIBEXECDIR)
+
+# Build the dso
+MOD_BACKTRACE_SRC = mod_backtrace.c
+
+$(SODIR)mod_backtrace.so: $(MOD_BACKTRACE_SRC)
+ $(APXS) $(APXS_FLAGS) -Wc,-Wall -c -lubacktrace $(MOD_BACKTRACE_SRC)
+
+install: $(SODIR)mod_backtrace.so
+ $(APXS) $(APXS_FLAGS) -S LIBEXECDIR=$(APXSLIBDIR) -n backtrace -i $(SODIR)mod_backtrace.so
+
+# Clean targets
+clean:
+ @rm -f *~ $(MOD_BACKTRACE_SRC:.c=.{la,lo,o,slo})
+ @rm -rf $(SODIR)
+
+realclean: clean
+ @rm -f config.log
+
+distclean: realclean
+ @rm -f config.h Makefile \
+ config.status config.cache
+ @rm -rf autom4te.cache