aboutsummaryrefslogtreecommitdiffstats
path: root/testing/audit
diff options
context:
space:
mode:
Diffstat (limited to 'testing/audit')
-rw-r--r--testing/audit/0004-path_max.patch23
-rw-r--r--testing/audit/APKBUILD9
2 files changed, 31 insertions, 1 deletions
diff --git a/testing/audit/0004-path_max.patch b/testing/audit/0004-path_max.patch
new file mode 100644
index 0000000000..a9892bb551
--- /dev/null
+++ b/testing/audit/0004-path_max.patch
@@ -0,0 +1,23 @@
+From ab123cbbffe90aefe1579d2708bae43e53e5afb4 Tue April 25 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Tue, 25 April 2017 12:33:43 +0000
+Subject: [PATCH] Define PATH_MAX if not defined
+
+PATH_MAX is not being defined on ppc64le, which causes a FTBFS.
+This patch check that it is defined, otherwise, defines it.
+
+Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+
+--- a/lib/libaudit.h
++++ b/lib/libaudit.h
+@@ -637,6 +637,10 @@
+ int audit_can_write(void);
+ int audit_can_read(void);
+
++#if !defined(PATH_MAX)
++#define PATH_MAX 4096
++#endif
++
+ #ifdef __cplusplus
+ }
+ #endif
diff --git a/testing/audit/APKBUILD b/testing/audit/APKBUILD
index 8c4f378ed4..21c5c61f57 100644
--- a/testing/audit/APKBUILD
+++ b/testing/audit/APKBUILD
@@ -8,19 +8,24 @@ arch="all"
license="GPLv2+"
depends=""
depends_dev="linux-headers"
-makedepends="$depends_dev libcap-ng-dev python3"
+makedepends="$depends_dev swig libcap-ng-dev python3"
install=""
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs"
source="http://people.redhat.com/sgrubb/audit/audit-$pkgver.tar.gz
0001-auditctl-include-headers-to-make-build-work-with-mus.patch
0002-auparse-remove-use-of-rawmemchr.patch
0003-all-get-rid-of-strndupa.patch
+ 0004-path_max.patch
auditd.initd
auditd.confd
"
builddir="$srcdir/audit-$pkgver"
build() {
+ if [ "$CARCH" = "ppc64le" ]; then
+ WITHOUT="--without-python3 --without-python"
+ fi
+
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -31,6 +36,7 @@ build() {
--localstatedir=/var \
--disable-zos-remote \
--enable-shared=audit \
+ $WITHOUT \
|| return 1
make || return 1
}
@@ -59,5 +65,6 @@ sha512sums="a3974547a6da15e87c9070f3aa8a40232555afbd8d6cdf41e6d3c2a059f766ae75fe
9070de8b9d778c2907adfcb78a02c3a243ed1951d399184679518493a7eca1560878616ace1f661005bda9384e8fc6fde103298c9c57d8883786210939927ecc 0001-auditctl-include-headers-to-make-build-work-with-mus.patch
bede955da1a31b42fbb259ea88cfca97e9a4263987e5982eeeee78a74524ce5f819872cbf404551dcce490ad188cd6a0eee65312ca7665c295581801c92bbb05 0002-auparse-remove-use-of-rawmemchr.patch
41c50d8203ba8d31bd0e4fbcacbf9f15d6d83aae77660d815aecfe75e0cd40e587730becb725431f0416da14468b85c7a13739040498869d64a30ef0602081c1 0003-all-get-rid-of-strndupa.patch
+c83183a7c530816b830777590f5e5f385aa81ecfee64249691a6d63310a053057bae90e60e3d68c4d2997f9e35f3589eecbe6dbdb6c53849888bd025cc4b9636 0004-path_max.patch
1b48c248db5d34f148f9c79f8b2a6acbf61c729230341b861f5e331bbfb0c8356305a09eb2cc5c82c14c4fd9a13c7c13957e1ed493834b8b3b9ee38978e4c31f auditd.initd
69d8777772ded7a8c0db2bcf84961b121bb355fa0d4ba0e14e311f8a8bfe665cbd2b7ac632d73477f9dfa9a6eec357a7ed458fe9b3e7b5ede75b166f3f092ab7 auditd.confd"