aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bluez/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bluez/APKBUILD')
-rw-r--r--testing/bluez/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
index b8a18a350e..6ccd959312 100644
--- a/testing/bluez/APKBUILD
+++ b/testing/bluez/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=4.64
-pkgrel=1
+pkgver=4.69
+pkgrel=2
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
license="GPL2"
depends=
-makedepends="dbus-dev gstreamer-dev alsa-lib-dev libusb-dev libnl-dev"
+makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev
+ libnl-dev"
subpackages="$pkgname-dev $pkgname-doc libbluetooth $pkgname-alsa $pkgname-cups
- $pkgname-netlink"
+ $pkgname-netlink $pkgname-gstreamer"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
bluetooth.initd
bluetooth.confd
@@ -44,6 +45,7 @@ package() {
make install DESTDIR="$pkgdir"
install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
install -Dm644 "$srcdir"/bluetooth.confd "$pkgdir"/etc/conf.d/bluetooth
+ install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
}
libbluetooth() {
@@ -72,6 +74,12 @@ netlink() {
"$subpkgdir"/usr/lib/bluetooth/plugins
}
-md5sums="d6e60bad937fe72b0bc77e327ee470b0 bluez-4.64.tar.bz2
+gstreamer() {
+ pkgdesc="Bluez plugin for gstreamer"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/gstreamer* \
+ "$subpkgdir"/usr/lib/
+}
+md5sums="350568aa11a95eac6e56e9289ff1f91d bluez-4.69.tar.bz2
66408fb89b05e7ce7e61c4c3c356d2c6 bluetooth.initd
a159d897a057f4675548327329c4cc22 bluetooth.confd"