aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bmake/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bmake/APKBUILD')
-rw-r--r--testing/bmake/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/bmake/APKBUILD b/testing/bmake/APKBUILD
index c204b67014..045473a2bb 100644
--- a/testing/bmake/APKBUILD
+++ b/testing/bmake/APKBUILD
@@ -12,14 +12,16 @@ source="http://www.crufty.net/ftp/pub/sjg/bmake-$pkgver.tar.gz
separate-tests.patch"
builddir="$srcdir/$pkgname"
+# Reset MAKEFLAGS since it might contain options not supported
+# by bmake. This is, for instance, the case on the builders.
+export MAKEFLAGS="-j${JOBS:-1}"
+
build() {
sh ./boot-strap --with-default-sys-path=/usr/share/mk op=build
}
check() {
- # Unset MAKEFLAGS since it might contain options not supported
- # by bmake. This is, for instance, the case on the builders.
- env MAKEFLAGS= sh ./boot-strap op=test
+ sh ./boot-strap op=test
}
package() {