aboutsummaryrefslogtreecommitdiffstats
path: root/testing/checkpolicy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/checkpolicy/APKBUILD')
-rw-r--r--testing/checkpolicy/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/checkpolicy/APKBUILD b/testing/checkpolicy/APKBUILD
new file mode 100644
index 0000000000..65caffab0a
--- /dev/null
+++ b/testing/checkpolicy/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tycho Andersen <tycho@docker.com>
+pkgname=checkpolicy
+pkgver=2.6
+pkgrel=0
+pkgdesc="SELinux policy checker"
+url="http://www.selinuxproject.org"
+arch="all"
+license="GPL2"
+makedepends="libsepol-dev bison flex-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/SELinuxProject/selinux/archive/checkpolicy-$pkgver.tar.gz
+ 0001-remove-apple-ifdef.patch
+ "
+builddir="$srcdir/selinux-checkpolicy-$pkgver/checkpolicy"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="24f617d1fbc17422ede258836cf7f90cf6ef1f018fe3848bcafd69a768b47e7fa2de31452f3ad76b15de4ef962b5d5c7313a42b718b9d905b096b2361f1a9b12 checkpolicy-2.6.tar.gz
+9392c01f4fe73ccf7bed865b9721b8f0d9d76068f68ec03af41e07fae7aede6d53627ca001585b171f973d2d83b4f2f65465de78597eba3b5e576b9c7aa903a7 0001-remove-apple-ifdef.patch"