aboutsummaryrefslogtreecommitdiffstats
path: root/testing/consul-template
diff options
context:
space:
mode:
Diffstat (limited to 'testing/consul-template')
-rw-r--r--testing/consul-template/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/testing/consul-template/APKBUILD b/testing/consul-template/APKBUILD
index fe53e036eb..8b97b963e8 100644
--- a/testing/consul-template/APKBUILD
+++ b/testing/consul-template/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=consul-template
-pkgver=0.20.1
+pkgver=0.21.0
pkgrel=0
pkgdesc="Generic template rendering and notifications with Consul"
url="https://www.consul.io/"
@@ -11,23 +11,17 @@ depends=""
makedepends="go"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
- mkdir -p "$builddir/src/github.com/hashicorp"
- ln -s "$builddir" "$builddir/src/github.com/hashicorp/$pkgname"
- cd "$builddir/src/github.com/hashicorp/$pkgname"
-
- GOPATH="$builddir" go build -v -o bin/$pkgname
+ CGO_ENABLED="0" go build -a -v -o bin/$pkgname \
+ -ldflags "-s -w
+ -X github.com/hashicorp/$pkgname/version.Name=$pkgname \
+ -X github.com/hashicorp/$pkgname/version.GitCommit=$pkgver"
}
package() {
- cd "$builddir"
-
# Main binary
install -m750 -D bin/$pkgname "$pkgdir"/usr/sbin/$pkgname
}
-sha512sums="b00e0ad0a5580d24be1d82fc89f9f725b233669cd7afb9673d502eecdf1535effb034627d99bb16d7bad5020cafd50312c1fd8575b41e427190b9b99e7cc9564 consul-template-0.20.1.tar.gz"
+sha512sums="98e06f143591c6394afc8e0b622944d2584c84fddf8324d1e0c749f2c215dd06cceb942cefa8fb59ac98c07c144b57691b14ffb1fe1dbd2907c951e0b214f302 consul-template-0.21.0.tar.gz"