aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cpputest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cpputest/APKBUILD')
-rw-r--r--testing/cpputest/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/testing/cpputest/APKBUILD b/testing/cpputest/APKBUILD
index 8f56f3eb46..dea7ee6ed8 100644
--- a/testing/cpputest/APKBUILD
+++ b/testing/cpputest/APKBUILD
@@ -2,11 +2,12 @@
# Maintainer: Shiva Velmurugan <shiv@shiv.me>
pkgname=cpputest
pkgver=3.8
-pkgrel=0
+pkgrel=1
pkgdesc="A unit testing and mocking framework for C/C++"
url="http://cpputest.github.io/"
arch="all"
license="BSD"
+options="!dbg"
makedepends="cmake"
subpackages="$pkgname-doc"
source="https://github.com/cpputest/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
@@ -16,19 +17,24 @@ build() {
mkdir -p "$builddir"/build
cd "$builddir"/build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr || return 1
- make || return 1
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ make test
}
package() {
cd "$builddir"/build
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/lib/cmake
mv "$pkgdir"/usr/lib/CppUTest/cmake \
- "$pkgdir"/usr/lib/cmake/CppUTest || return 1
- rmdir "$pkgdir"/usr/lib/CppUTest || true
+ "$pkgdir"/usr/lib/cmake/CppUTest
+ rmdir "$pkgdir"/usr/lib/CppUTest
install -Dm644 ../COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/COPYING