aboutsummaryrefslogtreecommitdiffstats
path: root/testing/crystal/makefile-allow-extra-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/crystal/makefile-allow-extra-flags.patch')
-rw-r--r--testing/crystal/makefile-allow-extra-flags.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/crystal/makefile-allow-extra-flags.patch b/testing/crystal/makefile-allow-extra-flags.patch
new file mode 100644
index 0000000000..c3a004592e
--- /dev/null
+++ b/testing/crystal/makefile-allow-extra-flags.patch
@@ -0,0 +1,23 @@
+From 746da810fd045ae2ccad8cecfd746375788b6bfb Mon Sep 17 00:00:00 2001
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 24 Mar 2018 18:20:59 +0100
+Subject: [PATCH] Makefile: Allow to add EXTRA_FLAGS to FLAGS
+
+Upstream-Issue: https://github.com/crystal-lang/crystal/pull/5860
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 2aa2e4fbdb..d18cd58e22 100644
+--- a/Makefile
++++ b/Makefile
+@@ -27,7 +27,7 @@
+ O := .build
+ SOURCES := $(shell find src -name '*.cr')
+ SPEC_SOURCES := $(shell find spec -name '*.cr')
+-FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )
++FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static ) $(EXTRA_FLAGS)
+ SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
+ EXPORTS := $(if $(release),,CRYSTAL_CONFIG_PATH=`pwd`/src)
+ SHELL = bash