aboutsummaryrefslogtreecommitdiffstats
path: root/testing/crystal/paxmark.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/crystal/paxmark.patch')
-rw-r--r--testing/crystal/paxmark.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/crystal/paxmark.patch b/testing/crystal/paxmark.patch
new file mode 100644
index 0000000000..db6efd89db
--- /dev/null
+++ b/testing/crystal/paxmark.patch
@@ -0,0 +1,22 @@
+Make tests run on Grsecurity system. This patch is downstream only.
+
+--- a/Makefile
++++ b/Makefile
+@@ -104,14 +104,17 @@
+ $(O)/all_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/all_spec.cr
++ paxmark m $(O)/all_spec
+
+ $(O)/std_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/std_spec.cr
++ paxmark m $(O)/std_spec
+
+ $(O)/compiler_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/compiler_spec.cr
++ paxmark m $(O)/compiler_spec
+
+ $(O)/crystal: $(DEPS) $(SOURCES)
+ @mkdir -p $(O)