aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ctop
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ctop')
-rw-r--r--testing/ctop/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/ctop/APKBUILD b/testing/ctop/APKBUILD
new file mode 100644
index 0000000000..e6893ce6a3
--- /dev/null
+++ b/testing/ctop/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Shyam Sunder <sgsunder1@gmail.com>
+# Maintainer: Shyam Sunder <sgsunder1@gmail.com>
+pkgname=ctop
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Top-like interface for container metrics"
+url="https://ctop.sh/"
+arch="all"
+license="MIT"
+depends="docker"
+makedepends="go dep"
+options="!check" # No test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/bcicen/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ make build
+}
+
+package() {
+ install -Dm755 "$builddir"/ctop \
+ "$pkgdir"/usr/bin/ctop
+}
+
+sha512sums="d5ef30800534b85b41215170f588cf2ad6460fb7a3fb1d1921ff1f8a7e6c515c76cdb2a089da1ae91067b3893e8a83fcea5616c2ace372bca2394dd57e22c887 ctop-0.7.2.tar.gz"