aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cunit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cunit/APKBUILD')
-rw-r--r--testing/cunit/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/cunit/APKBUILD b/testing/cunit/APKBUILD
deleted file mode 100644
index 7433118af3..0000000000
--- a/testing/cunit/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=cunit
-_pkgname=CUnit
-pkgver=2.1.3
-_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=0
-pkgdesc="Automated testing framework for C"
-url="http://cunit.sourceforge.net/"
-arch="all"
-license="GPL2"
-options="!check"
-makedepends="automake autoconf libtool bash"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
- path-makefile.patch"
-builddir="$srcdir/$_pkgname-$_pkgver"
-
-prepare() {
- cd "$builddir"
- libtoolize --force --copy
- aclocal
- autoheader
- automake --add-missing --include-deps --copy
- autoconf
-}
-
-build() {
- cd "$builddir"
- default_prepare
- ./configure \
- --prefix=/usr \
- --includedir=/usr/include \
- --datarootdir=/usr/share \
- --libdir=/usr/lib \
- --enable-debug \
- --enable-examples \
- --enable-automated \
- --enable-basic \
- --enable-test \
- --disable-static
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="b5f1a9f6093869c070c6e4a9450cc10c CUnit-2.1-3.tar.bz2
-975cfef465755b6cc5b946afb8dfcdd0 path-makefile.patch"
-sha256sums="f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214 CUnit-2.1-3.tar.bz2
-229dc40fdbbd918a9349f8c8bd49e0962de32ab6e249776c30661424a363c5f4 path-makefile.patch"
-sha512sums="547b417109332446dfab8fda17bf4ccd2da841dc93f824dc90a20635bcf1fb80fb2176500d8a0906940f3f3d3e2f77b2d70a71090c9ab84ad9af43f3582bc487 CUnit-2.1-3.tar.bz2
-94b9ef959ff9808c6adb2022a8c085232bc3ca0d5023584a13c35c6cb17b98674b7cc252d65d53a5b3db085f82853463ade7f9b910b564befe1d7b1e868de105 path-makefile.patch"