aboutsummaryrefslogtreecommitdiffstats
path: root/testing/debconf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/debconf/APKBUILD')
-rw-r--r--testing/debconf/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/debconf/APKBUILD b/testing/debconf/APKBUILD
new file mode 100644
index 0000000000..7e2f3f4bf6
--- /dev/null
+++ b/testing/debconf/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=debconf
+pkgver=1.5.71
+pkgrel=0
+pkgdesc="A configuration management system for Debian packages."
+url="https://packages.debian.org/debconf"
+arch="noarch"
+license="BSD-2-Clause"
+options="!check" # Test suite is broken. CopyDBTestSetup is missing new method
+depends="perl"
+makedepends="coreutils findutils po4a"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-utils $pkgname-bash-completion:bashcomp:noarch"
+source="https://deb.debian.org/debian/pool/main/d/debconf/debconf_$pkgver.tar.xz
+ fix-makefile_destdir.patch
+ "
+builddir="$srcdir/$pkgname"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX="/usr" DESTDIR="$pkgdir" install-i18n install-doc install-rest
+}
+
+utils() {
+ depends="$pkgname"
+ pkgdesc="Small utilities for debconf developers."
+
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$subpkgdir" install-utils
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ install -m 644 "$builddir"/bash_completion \
+ "$subpkgdir"/usr/share/bash-completion/completions/debconf
+ cd "$subpkgdir"/usr/share/bash-completion/completions
+ ln -s debconf debconf-show
+}
+
+sha512sums="ec6115a6aea78233e28f932f3eb6af62576b55211187a4253791c540ac74629029af01d95b5b382d01d51e1ae218760188a1eb865c04cc4d59a0006d8aa4c45b debconf_1.5.71.tar.xz
+86c8c0995921a15b67881a7f68f8db4fc785ebc05a03619f597bd71e3cfb628c0c5678b263d42715eded50c3c8b80a7e49a9671949a5f423936fc8801b262b9a fix-makefile_destdir.patch"