aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dosbox
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dosbox')
-rw-r--r--testing/dosbox/APKBUILD82
-rw-r--r--testing/dosbox/dosbox-0.74-formatsecurity.patch12
-rw-r--r--testing/dosbox/dosbox-0.74-gcc46.patch10
-rw-r--r--testing/dosbox/dosbox-0.74-init-crash.patch16
-rw-r--r--testing/dosbox/dosbox.desktop8
-rw-r--r--testing/dosbox/dosbox.pngbin206 -> 0 bytes
-rw-r--r--testing/dosbox/pic-fix.patch35
7 files changed, 0 insertions, 163 deletions
diff --git a/testing/dosbox/APKBUILD b/testing/dosbox/APKBUILD
deleted file mode 100644
index dd986a51d2..0000000000
--- a/testing/dosbox/APKBUILD
+++ /dev/null
@@ -1,82 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=dosbox
-pkgver=0.74
-pkgrel=1
-pkgdesc="x86/DOS emulator with sound and graphics"
-url="http://dosbox.com"
-arch="all"
-license="GPLv2+"
-depends="hicolor-icon-theme"
-depends_dev="libpng-dev sdl-dev alsa-lib-dev glu-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/project/dosbox/dosbox/$pkgver/dosbox-$pkgver.tar.gz
- dosbox-0.74-formatsecurity.patch
- dosbox-0.74-gcc46.patch
- dosbox-0.74-init-crash.patch
- pic-fix.patch
- dosbox.desktop
- dosbox.png
- "
-
-_builddir="$srcdir"/dosbox-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- update_config_sub
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-dynamic-core \
- --disable-dynamic-x86 \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- mkdir -p "$pkgdir"/usr/share/pixmaps \
- "$pkgdir"/usr/share/applications || return 1
- install -m644 "$srcdir"/dosbox.png "$pkgdir"/usr/share/pixmaps/\
- || return 1
- install -m644 "$srcdir"/dosbox.desktop \
- "$pkgdir"/usr/share/applications/ || return 1
-}
-
-md5sums="b9b240fa87104421962d14eee71351e8 dosbox-0.74.tar.gz
-9bb0b70a44151a33b50a6e07ed0a5658 dosbox-0.74-formatsecurity.patch
-d4534babc251a9ff12bf6ce27301de91 dosbox-0.74-gcc46.patch
-a90321ab0e29f65664317f61ff0abcb3 dosbox-0.74-init-crash.patch
-e87a9e420dd76f8832bb3fcd7ee7f9b7 pic-fix.patch
-f197a5de143e94f22c06c8ac3d6ea4d9 dosbox.desktop
-eca02a0e08f639122453a38cc5549eef dosbox.png"
-sha256sums="13f74916e2d4002bad1978e55727f302ff6df3d9be2f9b0e271501bd0a938e05 dosbox-0.74.tar.gz
-3bc0f22e3c47449e655aedcf316c50d634d8661874d3f236b2d9f1f74b67cc0a dosbox-0.74-formatsecurity.patch
-aea0e78a2e2d9963eb902aff9647cc35cb864e970f06d3ca0745e2b89a4e5ad6 dosbox-0.74-gcc46.patch
-99d892707cf1c9d119f0c510eca562c2b4b3fa4c8ad8cb11de37594352ca0f8e dosbox-0.74-init-crash.patch
-c8e072a7a0feccf50f3353ca728ac2be1f8da67641355053d88bf25004dc40c3 pic-fix.patch
-d1f5ef81ecb57987425bb250fb7e42f8fac6437e124d3986ab8037068c077c52 dosbox.desktop
-3c4361396fa6a61e2ade5c94b53f0a349193c66c133fdc04cd7cffd2faf86cd0 dosbox.png"
-sha512sums="4a6ff4c658997a495119d200ec6ad37649da940814a4b14fca0dd29a99142026e324695b7aa9d2946efc2abf9067a819d911e43778efe905ed10ddf9b9f2dd3d dosbox-0.74.tar.gz
-8ba824d754b7a804efa9c832608672d257d4978dc84f0035f32d48d312666107c3271158e2764d058d84b70caab0c0b5dff1fa93a72390d11b6dc7f655c50c31 dosbox-0.74-formatsecurity.patch
-115805d684ec5b5eb747fd46e4787d67fae0e6cf6622b52114031e82abb0db08b7bf98b2d2526a8336c41541d7202d429d7689e894a0abcd26599cd4be5768bf dosbox-0.74-gcc46.patch
-b7ee5c48e05a8de5b25eb35421167cf381fd21f1ff8cebf9da5671938d1a6dce05a78e05cd8db3178b233253ad9d8277c66ac38a302fc6cf9eaac4965e208822 dosbox-0.74-init-crash.patch
-f3711f0fc9039af6bc902eb9f70c433199cca655024897d248a7953df0b0eac1cd82301f5c55199e28573a49bd6182036c96d543935401e40d373c104a8576c5 pic-fix.patch
-882bf0c964c0041460780eb40548a2c5301eca4ff1fbdfd418a35ca98479dd2dce32c3fdfc31fe390ca3c3a5c4a523fa7ef025a13c6ed3457c7042fbb739d16c dosbox.desktop
-249db09d98b293e26189635018248780dd0eaefcb09c5bd9dc1b266547d54930bce413a7a50898872a5e70de2efc5ac665527ebe2450a505df724028d1261000 dosbox.png"
diff --git a/testing/dosbox/dosbox-0.74-formatsecurity.patch b/testing/dosbox/dosbox-0.74-formatsecurity.patch
deleted file mode 100644
index 6b518b702f..0000000000
--- a/testing/dosbox/dosbox-0.74-formatsecurity.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up dosbox-0.74/src/gui/sdlmain.cpp.orig dosbox-0.74/src/gui/sdlmain.cpp
---- dosbox-0.74/src/gui/sdlmain.cpp.orig 2013-12-18 15:06:41.227839719 +0100
-+++ dosbox-0.74/src/gui/sdlmain.cpp 2013-12-18 15:07:14.434769053 +0100
-@@ -1529,7 +1529,7 @@ static void show_warning(char const * co
- if ( !sdl.inited && SDL_Init(SDL_INIT_VIDEO|SDL_INIT_NOPARACHUTE) < 0 ) textonly = true;
- sdl.inited = true;
- #endif
-- printf(message);
-+ printf("%s", message);
- if(textonly) return;
- if(!sdl.surface) sdl.surface = SDL_SetVideoMode(640,400,0,0);
- if(!sdl.surface) return;
diff --git a/testing/dosbox/dosbox-0.74-gcc46.patch b/testing/dosbox/dosbox-0.74-gcc46.patch
deleted file mode 100644
index 8b19983a69..0000000000
--- a/testing/dosbox/dosbox-0.74-gcc46.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/dos_inc.h 2010-05-10 19:43:54.000000000 +0200
-+++ b/include/dos_inc.h 2011-03-16 09:46:24.430008904 +0100
-@@ -27,6 +27,7 @@
- #ifndef DOSBOX_MEM_H
- #include "mem.h"
- #endif
-+#include <stddef.h>
-
- #ifdef _MSC_VER
- #pragma pack (1)
diff --git a/testing/dosbox/dosbox-0.74-init-crash.patch b/testing/dosbox/dosbox-0.74-init-crash.patch
deleted file mode 100644
index 97a0966d6a..0000000000
--- a/testing/dosbox/dosbox-0.74-init-crash.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -up dosbox-0.74/src/gui/sdl_mapper.cpp~ dosbox-0.74/src/gui/sdl_mapper.cpp
---- dosbox-0.74/src/gui/sdl_mapper.cpp~ 2010-05-10 20:58:06.000000000 +0200
-+++ dosbox-0.74/src/gui/sdl_mapper.cpp 2013-05-10 20:53:02.133112189 +0200
-@@ -2384,9 +2384,11 @@ void MAPPER_StartUp(Section * sec) {
- mapper.sticks.num=0;
- mapper.sticks.num_groups=0;
- Bitu i;
-- for (i=0; i<16; i++) {
-+ for (i=0; i<MAX_VJOY_BUTTONS; i++) {
- virtual_joysticks[0].button_pressed[i]=false;
- virtual_joysticks[1].button_pressed[i]=false;
-+ }
-+ for (i=0; i<16; i++) {
- virtual_joysticks[0].hat_pressed[i]=false;
- virtual_joysticks[1].hat_pressed[i]=false;
- }
diff --git a/testing/dosbox/dosbox.desktop b/testing/dosbox/dosbox.desktop
deleted file mode 100644
index 8455c5cfa2..0000000000
--- a/testing/dosbox/dosbox.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=DOSBox
-Comment=An x86/DOS emulator with sound/graphics
-Exec=dosbox
-Icon=dosbox.png
-Terminal=false
-Type=Application
-Categories=System;Emulator;
diff --git a/testing/dosbox/dosbox.png b/testing/dosbox/dosbox.png
deleted file mode 100644
index 5945b2c902..0000000000
--- a/testing/dosbox/dosbox.png
+++ /dev/null
Binary files differ
diff --git a/testing/dosbox/pic-fix.patch b/testing/dosbox/pic-fix.patch
deleted file mode 100644
index 74d26ff441..0000000000
--- a/testing/dosbox/pic-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --exclude '*.*o' -ru dosbox-0.74.orig/include/dos_inc.h dosbox-0.74/include/dos_inc.h
---- dosbox-0.74.orig/include/dos_inc.h 2010-05-10 20:43:54.000000000 -0300
-+++ dosbox-0.74/include/dos_inc.h 2014-07-17 11:00:44.418771087 -0300
-@@ -21,6 +21,7 @@
- #ifndef DOSBOX_DOS_INC_H
- #define DOSBOX_DOS_INC_H
-
-+#include <stddef.h>
- #ifndef DOSBOX_DOS_SYSTEM_H
- #include "dos_system.h"
- #endif
-diff --exclude '*.*o' -ru dosbox-0.74.orig/src/cpu/core_dyn_x86/risc_x86.h dosbox-0.74/src/cpu/core_dyn_x86/risc_x86.h
---- dosbox-0.74.orig/src/cpu/core_dyn_x86/risc_x86.h 2010-05-10 20:43:54.000000000 -0300
-+++ dosbox-0.74/src/cpu/core_dyn_x86/risc_x86.h 2014-07-17 11:00:12.432277706 -0300
-@@ -112,7 +112,7 @@
- pop ebx
- mov [retval],eax
- }
--#elif defined (MACOSX)
-+#elif defined (MACOSX) || defined (__PIC__)
- register Bit32u tempflags=reg_flags & FMASK_TEST;
- __asm__ volatile (
- "pushl %%ebx \n"
-diff --exclude '*.*o' -ru dosbox-0.74.orig/src/cpu/cpu.cpp dosbox-0.74/src/cpu/cpu.cpp
---- dosbox-0.74.orig/src/cpu/cpu.cpp 2010-05-12 12:57:31.000000000 -0300
-+++ dosbox-0.74/src/cpu/cpu.cpp 2014-07-17 10:57:04.226630637 -0300
-@@ -19,6 +19,7 @@
- /* $Id: cpu.cpp,v 1.116 2009-03-16 18:10:08 c2woody Exp $ */
-
- #include <assert.h>
-+#include <stddef.h>
- #include <sstream>
- #include "dosbox.h"
- #include "cpu.h"
-