aboutsummaryrefslogtreecommitdiffstats
path: root/testing/elektra/cmake-allow-override-rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/elektra/cmake-allow-override-rpath.patch')
-rw-r--r--testing/elektra/cmake-allow-override-rpath.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/elektra/cmake-allow-override-rpath.patch b/testing/elektra/cmake-allow-override-rpath.patch
new file mode 100644
index 0000000000..bc7f106d0c
--- /dev/null
+++ b/testing/elektra/cmake-allow-override-rpath.patch
@@ -0,0 +1,13 @@
+Allow to override CMAKE_INSTALL_RPATH.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,7 +7,7 @@
+
+ #fix macOS RPATH issues
+ set(CMAKE_MACOSX_RPATH 1)
+-SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
++SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib" CACHE STRING "The rpath to use for installed targets.")
+
+ #additional modules for loading libraries
+ set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")