aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ell/APKBUILD')
-rw-r--r--testing/ell/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/ell/APKBUILD b/testing/ell/APKBUILD
index 684119dcec..6d40ecda59 100644
--- a/testing/ell/APKBUILD
+++ b/testing/ell/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=ell
pkgver=0.17
-pkgrel=0
+pkgrel=1
pkgdesc="Linux library for embedded development"
url="https://01.org/ell"
arch="all"
license="GPL-2.0-only"
depends=""
-makedepends="glib-dev"
-options="!check" #Currently some tests fail. This is an environmental problem to test
+makedepends="glib-dev linux-headers"
+checkdepends="dbus"
subpackages="$pkgname-dev"
-source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz"
+source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz
+ musl-fixes-testsuite.patch
+ fix-utf8.patch"
builddir="$srcdir/$pkgname-${pkgver}"
build() {
@@ -37,4 +39,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="2f35214283bc2b0d17b27a096a0457679747966cad284e3bc581b9414909f98eb3bae9c33d30e62992dccf2331886af505a07e6a73df4c54d3ac476f6791da56 ell-0.17.tar.gz"
+sha512sums="2f35214283bc2b0d17b27a096a0457679747966cad284e3bc581b9414909f98eb3bae9c33d30e62992dccf2331886af505a07e6a73df4c54d3ac476f6791da56 ell-0.17.tar.gz
+ee93edab6618343bec00db9c4a5279a8f4cbb6ecf6ae62cac99c688377bb4ca4f04d5bc6a32a702071d16e8988f4c0eff2291fb04e91b8f9ed909ce88329f67f musl-fixes-testsuite.patch
+6973f65fff8b281d56b25b0abc1dd3673953ae6c1c234da94608148937afc783417398300cc090f841668cf1a898d2780b6f109539ce108949258cac1edfcd4c fix-utf8.patch"