aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fotoxx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/fotoxx/APKBUILD')
-rw-r--r--testing/fotoxx/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/fotoxx/APKBUILD b/testing/fotoxx/APKBUILD
new file mode 100644
index 0000000000..0edb118536
--- /dev/null
+++ b/testing/fotoxx/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fotoxx
+pkgver=11.06
+pkgrel=0
+pkgdesc="Photo editing and collection management"
+url="http://kornelix.squarespace.com/fotoxx"
+arch="all"
+license="GPL-3"
+depends="xdg-utils exiftool"
+makedepends="gtk+-dev tiff-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://kornelix.squarespace.com/storage/downloads/fotoxx-$pkgver.tar.gz
+ no-execinfo.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -e 's:/bin/bash:/bin/sh:' -i dependencies.sh
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr LDFLAGS="$LFDLAGS" CXXFLAGS="$CFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="e636e10f6a46f0a813e704f18eac3176 fotoxx-11.06.tar.gz
+981323960d1316051b898ba194085205 no-execinfo.patch"