aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ghc-bootstrap/Dockerfile.x86_64
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ghc-bootstrap/Dockerfile.x86_64')
-rw-r--r--testing/ghc-bootstrap/Dockerfile.x86_6417
1 files changed, 8 insertions, 9 deletions
diff --git a/testing/ghc-bootstrap/Dockerfile.x86_64 b/testing/ghc-bootstrap/Dockerfile.x86_64
index 997bbd0fd3..7a99c60fdf 100644
--- a/testing/ghc-bootstrap/Dockerfile.x86_64
+++ b/testing/ghc-bootstrap/Dockerfile.x86_64
@@ -96,7 +96,9 @@ run echo GCC_BUILTIN_PREREQS=yes >> config.sh && \
echo MAKEFLAGS=-j$(grep -c processor /proc/cpuinfo) >> config.sh && \
echo "BINUTILS_CONFFLAGS='CXXFLAGS=-fpermissive --enable-gold --enable-plugins --disable-werror'" >> config.sh && \
echo "CFLAGS='-g -O3 -fno-pie -fno-pic'" >> config.sh
-run ./build.sh && \
+copy gmpurl.patch gmpurl.patch
+run patch -p1 < gmpurl.patch && \
+ ./build.sh && \
rm -fr /tmp/musl-cross
add http://downloads.haskell.org/~ghc/$ghc/ghc-$ghc-src.tar.xz /tmp/
@@ -107,8 +109,12 @@ run openssl sha1 ghc-$ghc-src.tar.xz | grep "SHA1(ghc-$ghc-src.tar.xz)= 0e0ae6d5
workdir /tmp/ghc-$ghc
copy bootstrap.patch bootstrap.patch
copy rm-ghc-pwd.patch rm-ghc-pwd.patch
+copy build-unlit-twice.patch build-unlit-twice.patch
+copy build-hp2ps-twice.patch build-hp2ps-twice.patch
run patch -p1 < bootstrap.patch && \
- patch -p1 < rm-ghc-pwd.patch
+ patch -p1 < rm-ghc-pwd.patch && \
+ patch -p1 < build-unlit-twice.patch && \
+ patch -p1 < build-hp2ps-twice.patch
run cp mk/build.mk.sample mk/build.mk && \
./boot && \
echo "BuildFlavour = perf-llvm" >> mk/build.mk && \
@@ -127,13 +133,6 @@ run cp mk/build.mk.sample mk/build.mk && \
run make -j$(grep -c processor /proc/cpuinfo) || make -j1
run make -j1 install DESTDIR=$destdir
-run find $destdir -name "*hp2ps" -exec rm {} \;
-
-# remove target prefix from stage2 binaries
-# HACK, just build unlit with the cross compiler and move it to /usr/bin in the install dir
-workdir /tmp/ghc-$ghc/utils/unlit
-run $crosscc unlit.c -o $(find $destdir -name unlit)
-
# remove target prefix from stage2 binaries
workdir $destdir/usr/bin
run (for i in $triple-* ; do ln -s $i ${i#$triple-} || /bin/true; done ) && \