aboutsummaryrefslogtreecommitdiffstats
path: root/testing/global
diff options
context:
space:
mode:
Diffstat (limited to 'testing/global')
-rw-r--r--testing/global/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/global/APKBUILD b/testing/global/APKBUILD
index ba56588877..d69724c7fd 100644
--- a/testing/global/APKBUILD
+++ b/testing/global/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
# Maintainer:
pkgname=global
-pkgver=6.5.5
+pkgver=6.5.7
pkgrel=0
pkgdesc="A source code tag system"
url="http://www.gnu.org/software/global"
@@ -11,23 +11,26 @@ depends=""
makedepends="libltdl perl"
subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/global/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
./configure \
--prefix=/usr \
--localstatedir=/var \
--with-exuberant-ctags=/usr/bin/ctags \
- --disable-gtagscscope \
- || return 1
- make check || return 1
- make || return 1
+ --disable-gtagscscope
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./global/global --version
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
+ make DESTDIR="$pkgdir/" install
install -d "$pkgdir"/usr/share/emacs/site-lisp
install -d "$pkgdir"/usr/share/vim/vimfiles/plugin
@@ -36,6 +39,4 @@ package() {
mv "$pkgdir"/usr/share/gtags/gtags-cscope.vim "$pkgdir"/usr/share/vim/vimfiles/plugin/gtags-cscope.vim
}
-md5sums="ee1c0ac678385fed77c90369a1ccfe65 global-6.5.5.tar.gz"
-sha256sums="bc5b42a2c58d1570ff6b6acf7479c3e1609fe0ec8b44e5baa5290dc47148cf7b global-6.5.5.tar.gz"
-sha512sums="5f8d09710f534f0ebfcdabb85e3a094402a6ef56b800d94eb5ba546b3aa5cbdeb664fa37edcd46530b34a734fc05a1271e4abc8bb13e24db2c5cb2dbb46a4481 global-6.5.5.tar.gz"
+sha512sums="0d33f718839e5e00bdd6d042b415a69c5e1f232d843610870505f8f20635b445810149b1b84ea8b77881f5f64814783ebe3cdcab2f84b8a085223b64293a9045 global-6.5.7.tar.gz"