aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-shell
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gnome-shell')
-rw-r--r--testing/gnome-shell/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/gnome-shell/APKBUILD b/testing/gnome-shell/APKBUILD
index 2c15ea3e69..c58ae1ce6c 100644
--- a/testing/gnome-shell/APKBUILD
+++ b/testing/gnome-shell/APKBUILD
@@ -45,9 +45,14 @@ makedepends="gnome-desktop-dev
py3-setuptools
gnome-bluetooth-dev
gstreamer-dev"
+checkdepends="
+ xvfb-run
+ mesa-dri-swrast
+ gdm
+ "
subpackages="$pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/gnome-shell/${pkgver%.*}/gnome-shell-$pkgver.tar.xz"
-options="!check" # Requires running X11 server
+options="!check" # Tests have circular dependency 'gnome-shell <-> gdm'
build() {
meson \
@@ -62,7 +67,7 @@ build() {
}
check() {
- ninja -C output test
+ xvfb-run ninja -C output test
}
package() {